Closed Bug 578788 Opened 11 years ago Closed 11 years ago

Teach xpidl.py how to output typelibs

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 458936

People

(Reporter: ted, Unassigned)

References

()

Details

I wrote a Python XPT reader/writer library (linked in the URL). We should hook it up to xpidl.py, and then we can switch the build system to use xpidl.py instead of the binary xpidl for producing typelibs. Once bug 578478 is also fixed, we can drop the binary xpidl completely (including our build-time dependencies on glib/libIDL).
Blocks: 578790
Wouldn't it be nicer for everyone if the resulting program was called xpidl instead of xpidl.py ? (at least on unix systems, where extensions are irrelevant)
This looks like a dupe of bug 458936?
You would think I would know these things, seeing as how I commented there and everything.
No longer blocks: 578790
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458936
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.