'cfx testall -a firefox' is broken on latest Firefox 4.0b2pre nightlies

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: avarma, Assigned: avarma)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Whenever I run 'cfx testall -a firefox' with the latest nightlies, the test suite hangs here:

  Testing all available packages: nsjetpack, test-harness, jetpack-core,  
  development-mode.

Firefox opens, but no errors appear in the JS error console (aside from "Warning: unrecognized command line flag -foreground", which has been around for a while on OS X), nor on stdout.

This appears to be happening to peregrino and Myk too. Myk is using Linux and I'm using OS X.
(Assignee)

Comment 1

8 years ago
Note also that this is after the patch for bug 578432 has landed, so install.rdf maxVersion shouldn't be an issue here. In fact, going to the Add-ons Manager while Firefox is "hanging" does show the test harness addon as being installed and enabled.
what do you see when you try cfx run inside a package dir? because that's failing for me on nightlies.
(Assignee)

Comment 3

8 years ago
Ok, found it with Mossop's help... It's bug 568691 that's causing the harness.js XPCOM component to not be loaded. In order to fix this, we either need to have cfx create a chrome.manifest in the extension dir with harness.js's cid info in it, or, now that bug 566485 is fixed, actually fix bug 566723. I'm going to go for the latter since it's both a cleaner fix and requires less work.
Assignee: nobody → avarma
Status: NEW → ASSIGNED
Depends on: 566723
(Assignee)

Comment 4

8 years ago
Created attachment 458472 [details] [diff] [review]
patch
(Assignee)

Comment 5

8 years ago
Comment on attachment 458472 [details] [diff] [review]
patch

Mossop, can you take a quick look at this and let me know if it looks sane?
Attachment #458472 - Flags: review?(dtownsend)
Comment on attachment 458472 [details] [diff] [review]
patch

Looks good, though I might suggest adding a comment in harness.js above NSGetModule saying that everything below there is only used on Gecko 1.9.2.
Attachment #458472 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 7

8 years ago
Thanks! I added the comment and pushed:

Bug 578842 - 'cfx testall -a firefox' is broken on latest Firefox 4.0b2pre nightlies
Atul Varma
http://hg.mozilla.org/labs/jetpack-sdk/rev/ca9796a2a6aa
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 574122
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.