[exit] mozmill should shut down firefox if it fails to connect to jsbridge

RESOLVED FIXED

Status

Testing Graveyard
Mozmill
RESOLVED FIXED
8 years ago
a year ago

People

(Reporter: Jeff Hammel, Assigned: Jeff Hammel)

Tracking

Details

(Whiteboard: [mozmill-2.0+])

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
currently, mozmill uses mozrunner to start firefox then attempts to wait_and_create the jsbridge network.  if the latter fails, firefox is still running.  instead, mozmill should shut it down
See also bug 510960
(Assignee)

Updated

8 years ago
Whiteboard: [mozmill-2.0?]
(Assignee)

Updated

7 years ago
Summary: mozmill should shut down firefox if it fails to connect to jsbridge → [exit] mozmill should shut down firefox if it fails to connect to jsbridge
(Assignee)

Comment 2

7 years ago
Reproduction steps:

1. invoke (e.g.) `mozmill -m /home/jhammel/mozilla/src/mozilla-central/testing/mozmill/tests/firefox/manifest.ini --show-all`
2. before the tests can run, press ctrl+c or equivalent

mozmill will quit but firefox will hang.

This was fixed for 1.5.2, but evidently never ported to 2.0
Assignee: nobody → jhammel
(Assignee)

Updated

7 years ago
Whiteboard: [mozmill-2.0?] → [mozmill-2.0+]
(Assignee)

Comment 3

7 years ago
Created attachment 508904 [details] [diff] [review]
mozmill should shut down firefox if it fails to connect to jsbridge

Turns out this was probably already fixed for 90+% of exceptions in the wild.  This will additionally fix it for exceptions that don't inherent from base exceptions and additionally not (mistakely) reraise the exception until after the results reporting gets done
Attachment #508904 - Flags: review?(fayearthur+bugs)
(Assignee)

Updated

7 years ago
Duplicate of this bug: 616195
Comment on attachment 508904 [details] [diff] [review]
mozmill should shut down firefox if it fails to connect to jsbridge

lg
Attachment #508904 - Flags: review?(fayearthur+bugs) → review+
(Assignee)

Comment 6

7 years ago
push to master as https://github.com/mozautomation/mozmill/commit/321541d9adb947339c4f1ad0cff14cb4649e4145
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.