undergroundcross.com - [LAYER] javascript error leaves some pages unviewable

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P3
major
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Dan, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
the script on this page shows the browser a "loading page" screen while the page
is loading, and then is supposed to roll away, showing the page.  On the above
URL (http://www.undergroundcross.com) the page loads, the "loading page" screen
shows, but the loading page never roles away, making the page virually usless.
As I have seen this effect used in many places, I feel this is pretty important
bug, but then again I am no expert.  Good Luck Solving it! Great browser!
Sincerely,
Daniel Zeccola

Comment 1

17 years ago
Unfortunately the page can't cope with a browser that does things the standard
way. It checks for IE and Netscape extensions, and if it finds neither leaves
the 'loading screen' up. As the old NN extension it checks for is no longer
supported, it does the same with Mozilla.

[Needs to detect the right UA, then one line fix to use the DOM. Looks fine
offline, having done so]. 

Comment 2

17 years ago
Here is the code that Richard is referring to:


//Browsercheck
n=document.layers
ie=document.all


//Hides the layer onload
function hideIt(){
   if(ie || n){
      if(n) document.divLoadCont.visibility="hidden"
      else divLoadCont.style.visibility="hidden"
   }
}



Richard is right, the site uses insufficient browser detection.
The site only performs if the variables "n" or "ie" above evaluate to true.
But this won't happen in N6/Mozilla,  because neither document.all nor 
document.layers are supported.
 

See bug 50711 for further references. Reassigning to Evangelism  -
Assignee: rogerl → blakeross
Component: Javascript Engine → Evangelism
QA Contact: pschwartau → zach
Summary: javascript error leaves some pages unviewable → [LAYER] javascript error leaves some pages unviewable

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Hardware: PC → All

Comment 4

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
(Assignee)

Comment 5

17 years ago
Arun, I'm giving you all the Linux bugs. If these bugs can be confirmed for
other OS's please (someone) change the Platform/OS to All/All and reassign to
the default Evangelism Component Owner.
Assignee: bclary → aruner
(Assignee)

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 7

17 years ago
Arun, I am taking your Linux bugs minus banks. Hope you don't mind.
Assignee: aruner → bclary
(Assignee)

Updated

17 years ago
Summary: [LAYER] javascript error leaves some pages unviewable → undergroundcross.com - [LAYER] javascript error leaves some pages unviewable

Comment 8

16 years ago
yup, fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
Verified
2002040303/WinXP
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.