Can't seem to copy/paste in Bespin editor provided by the Addons Builder

VERIFIED FIXED

Status

Mozilla Labs Graveyard
FlightDeck
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Brian Crowder, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
CTRL-c/x/v don't seem to do anything, neither do CTRL-C/X/V and it is difficult to discover any other technique for doing this.
Can't replicate on 

1. Gentoo Linux / wmii / FF 3.6.6
2. OSX / FF 3.6.6
(Reporter)

Comment 2

7 years ago
My platform is Windows 7, can I offer any additional debug information for this?
Blocks: 577738
No longer blocks: 577738
Depends on: 577738

Comment 3

7 years ago
Confirming that I can't copy/cut on Windows 7. I'm using trunk.

Comment 4

7 years ago
Have been informed via the google group that it's a bespin issue. I'm assuming there's already a bug files, perhaps we mark this as a dupe and elevate the priority?
(Reporter)

Comment 5

7 years ago
This bug will be fixed by an upgrade to a newer version of Bespin, which is why it's being tracked as depending on bug 577738.
Been a couple of months. Are we any closer to having this work? It makes Flightdeck very frustrating, since you can't quickly copy things from the docs/tutorials into the editor to try out.
Duplicate of this bug: 585746
It seems it's not fixed in Bespin 0.8 (dev version is installed ...)
We will try to use Bespin 0.9 as soon as it will hit the door
Cc'ing Kevin - is this a known problem in 0.8? Is there a Skywriter bug tracking the problem, and if so is it targeting 0.9?

Comment 10

7 years ago
I'm surprised that this is the first I've heard of this. AFAIK, there are no outstanding copy/paste bugs with Bespin 0.9, but we'll take a look at the latest release on Windows to be sure.
I'm seeing the problem on Linux, switching OS -> All. Thanks for looking Kevin!
OS: Windows 7 → All
Hardware: x86 → All

Comment 12

7 years ago
OK, I just checked both Bespin 0.8.2 and 0.9a2 in Windows (Windows 7 running in VMware Fusion). I also tested the current Addons Builder.

In Bespin 0.8.2 and Addons Builder, I was able to paste text into the editor. I was not able to copy text that was in the editor.

With Bespin 0.9a2, I was able to copy text that was in the editor and paste it back into the editor (in other words, copy/paste worked just fine).

Comment 13

7 years ago
What is the AOB running right now?
It is 0.8
I tried to update to the newest, but something is changed in the SkyWriter (repository?) and I'm unable to update from hg, (I think) github one has the nodeJS builder which is not working yet for me.
Could someone point me to a current doc how to build embedded Bespin?
Or give me the latest source build with this manifest: https://github.com/mozilla/FlightDeck/blob/master/tools/bespin-manifest.json

Comment 15

7 years ago
Could you try the 0.9a2 release?

http://ftp.mozilla.org/pub/mozilla.org/labs/bespin/Embedded/BespinEmbedded-0.9a2.tar.gz
Bespin updated to 0.9a2

Please check on http://flightdeck.zalewa.info/

There is currently a bug there which doesn't allow to create Add-on - please edit the Library
This appears fixed on the frozen 1.0a7 release.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
1.06

Comment 19

7 years ago
Verified on trunk 

http://flightdeck.zalewa.info/
Status: RESOLVED → VERIFIED

Updated

7 years ago
Component: FlightDeck → FlightDeck
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.