SVG cross-document <use> + full-page-zoom + reload --> page gets painted with junk from random areas of the browser

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
STEPS TO REPRODUCE:
 1. Load testcase (coming up)
 2. Zoom in all the way (with ctrl & mousewheel or ctrl and +)
 3. Reload the page.  (repeat, if nothing happens the first time)

ACTUAL RESULTS:
 (a) Upper-left chunk of page gets redrawn at a reduced size.
 (b) The rest of the page (bottom & right) gets random content painted onto it.

If I switch tabs or resize the Firefox window, the problem goes away until I reload again. (I'm using Compiz effects on Ubuntu, btw -- from glancing at this problem yesterday, I think the problem persists even longer if I disable Compiz)

Not a recent regression -- affects m-c nightlies as well as Firefox 3.5.10:
Mozilla/5.0 (X11; Linux i686; en-US; rv:2.0b2pre) Gecko/20100714 Minefield/4.0b2pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.10) Gecko/20100504 Firefox/3.5.10
(Reporter)

Comment 1

8 years ago
Created attachment 457612 [details]
helper SVG file, used by testcase
(Reporter)

Comment 2

8 years ago
Created attachment 457615 [details]
ignore; broken version of testcase 1
(Reporter)

Comment 3

8 years ago
Created attachment 457616 [details]
testcase 1
Attachment #457615 - Attachment is obsolete: true
(Reporter)

Updated

8 years ago
Attachment #457615 - Attachment description: testcase 1 → ignore; broken version of testcase 1
(Reporter)

Comment 4

8 years ago
Created attachment 457618 [details]
screenshot 1: after zooming, but before reloading
(Reporter)

Comment 5

8 years ago
Created attachment 457619 [details]
screenshot 2: after zooming + reloading [BROKEN]
(Reporter)

Comment 6

8 years ago
Created attachment 457622 [details]
screenshot 3: after zooming + reloading + resizing window slightly [BROKEN]

Here's the 3rd of 3 screenshots, taken in Firefox 3.5. (m-c has essentially the same behavior)

This one is after I've resized the window slightly.  The corruption goes away, as you can see, but the large zoom value is no longer respected.  (so I was slightly incorrect in this chunk of comment 0: "If I switch tabs or resize the Firefox window, the problem goes away").
(Reporter)

Updated

8 years ago
Summary: SVG cross-document <use> + full-page-zoom + reload --> Junk repainted from random areas of screen → SVG cross-document <use> + full-page-zoom + reload --> page gets painted with junk from random areas of the browser
Sounds a lot like bug 460291 bug 460291 comment 21 gives a regression range for that one. Is this the same? This looks like a simpler testcase so if it is you could dup that to this.
Actually bug 460291 comment 21 regression range is just when cross doc was first implemented so that's not much use.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 460291
(Reporter)

Comment 10

8 years ago
(In reply to comment #7)
> Sounds a lot like bug 460291 [...] Is this the same?

Based on the screenshot and description there, yes -- I think it is.  Duped that to this -- thanks for the suggestion.

RE the regression range -- I couldn't verify that directly, since nightlies from around around 2008/10 all crash during startup on my machine due to a pango library mismatch or something.  

However, I was able to run a slightly later nightly that I have on hand, and it reproduced this bug:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081121 Minefield/3.1b2pre
(though in this build I just got chunks of white, rather than chunks of repainted junk. Looks basically like the same issue though)
This seems to work now. Perhaps the patch for bug 621253 fixed it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.