blank lines / whitespace is getting eaten in plain text email

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
--
minor
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Jack Eidsness, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre ( .NET CLR 3.5.30729)
Build Identifier: http://hg.mozilla.org/mozilla-central/rev/82edf5bd1abe

If I have an email that includes a reply marked by "> " and there is reply text below quoted text, e.g.

---- start ----
> from previous message

Original text to currently viewed message
---- end ----

. . . the blank line is getting eaten and it is hard to follow.

Reproducible: Always

Steps to Reproduce:
1. Reply to an email in plain text
2. Insert a statement after or between quoted text
3. Send the email, and make sure you get a copy
4. Read the email.

Actual Results:  
The quoted ("> ") text is replaced by a colored line to the left.  This is nice. Immediately after the quoted text, if the author included a blank line before, there isn't anymore.

I will roughly simulate it here:

| This is quoted text quoted text quoted text quoted text quoted text.
| This is quoted text quoted text quoted text quoted text quoted text.
This looks like it's part of the same paragraph, but it's not even 
the same author.

There is about an extra pixel, more than if it were just two ordinary lines
of text, but it's definitely not enough to visually separate the quoted
text from new text.

Expected Results:  
| This is quoted text quoted text quoted text quoted text quoted text.

The blank line right above this one, if included by the author, should either not be consumed, or if it is consumed, it should be replaced by enough vertical whitespace to serve the same purpose.

I am using a relatively recent win32 nightly of Shredder.

I just restarted for the latest update, confirmed the bug is still present.
http://hg.mozilla.org/mozilla-central/rev/5355f245b916
Whiteboard: dupme
I can't reproduce with a (well-populated) profile in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.7) Gecko/20100713 Lightning/1.0b2 Thunderbird/3.1.1, so this may be a regression on trunk.

Can you try creating a new profile (https://support.mozillamessaging.com/en-US/kb/Profiles#More_resources) to make sure it appears there too?
If it does, attaching a problematic email may be helpful.
Severity: normal → minor
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
I wish I'd taken a screenshot at the time, because I'm doubting myself now.  Similar emails seem not at all hard to follow.  I see that quoted text is in an entirely different color from new text in a reply, and I wonder if that's what was different for a day or two.
Closing as WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.