If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Move message won't work because GetURI returns wrong uri

VERIFIED FIXED in M6

Status

MailNews Core
Backend
P1
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: scottputterman, Assigned: Alec Flett)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix wasn't XP, new fix ready to check in)

(Reporter)

Description

19 years ago
When doing a move, NS_IMETHODIMP nsMailboxUrl::GetURI(char ** aURI)
 returns the wrong result because it calls
nsBuildLocalMessageURI(m_spec, m_messageKey, &uri);
 which expets a uri, but instead is being passed a path.

Because of this, move message will copy the message, but won't delete it from
the original folder and the message counts will look wrong.
(Reporter)

Updated

19 years ago
Target Milestone: M5

Updated

19 years ago

Updated

19 years ago
Whiteboard: investigating
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: investigating → Problem found, still trying to figure out correct fix

Updated

19 years ago
Whiteboard: Problem found, still trying to figure out correct fix → Problem found, testing fix now
(Assignee)

Comment 1

19 years ago
Got a fix!
Waiting for approval
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Fix is in!

Comment 3

19 years ago
Does this also fix bug 5676?
(Assignee)

Comment 4

19 years ago
yep
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Assignee)

Comment 5

19 years ago
So it turns out my bug doesn't account for file separator differences between
platforms. I'm testing out a fix on mac and windows now.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
Whiteboard: Problem found, testing fix now → fix wasn't XP, new fix ready to check in
(Assignee)

Comment 6

19 years ago
Ok, fix works. I'm using nsFilePath's to normalize the path into a URI-friendly
format.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Assignee)

Comment 7

19 years ago
New fix checked into SeaMonkey_M5_BRANCH and the Tip.

Comment 8

19 years ago
Pasting comments from 5676 which is a bug on the menu item and not on move
functionality.

- begin pasted comments:
------- Additional Comments From fenella@netscape.com  05/04/99 13:58 -------
More findings on the 1999-05-04-08 build
If I close apprunner,  run apprunner and open messenger again, the message shows
it made a copy to the folder, the original copy was not moved.

------- Additional Comments From putterman@netscape.com  05/04/99 14:09 -------
The problem is that the Delete part of the move and the copy header part of the
move are not taking place.  The actual copying of the message is happening.
It's because GetURI is returning mailbox_message://host//Inbox instead of
mailbox_message://host/Inbox on Linux.  Unless this is a total QA stopper (and
it works on Windows so we can still test Move Message), this probably won't get
fixed for M5 since the code has to be rewritten for M6 and any change to M5 will
just be temporary.  I'll let Alec expand on this.
-end pasted comments.

FWIW, the build Fenella references is a M6 build, not the M5 branch build.

Comment 9

19 years ago
Alec, this is actually checked in on all platforms for M6, right?  If so, I'm
gong to change the target milestone to M6 so we're more accurate on when to
verify.
(Assignee)

Comment 10

19 years ago
Yes, both M5 and M6. It's still broken on Linux (it does a copy instead of a
move) I have a feeling mac behaves the same way.

Comment 11

19 years ago
Yes, for M5 - Linux and Mac do a copy.  Win32 doesn't work at all (due to no
folders in the menu item).

For M6 - Linux and Mac still do a copy.  Win32 works fine.

Should this bug be reopened?
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED
Target Milestone: M5 → M6
(Assignee)

Comment 12

19 years ago
Yeah - Moving to M6 and reopening.

Comment 13

19 years ago
Using build 1999050423 M5 out of the 1999-05-05-06-M5 directory on Win95 Move
works.  Note: on Win95 it moves like it should, does not copy like linux and
mac.  I will check bug 5676 to see if it can be verified now that the menu item
shows up, and leave this one opened for functionality not working on (2)
platforms.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
(Assignee)

Comment 14

19 years ago
Fix checked in to remove leading / on URI fragment that was causing double "//"
on unix.

Updated

19 years ago
QA Contact: 4080 → 4104

Comment 15

19 years ago
Fenella, pls verify this for all platforms.

Comment 16

19 years ago
Move message is crashing for me on NT 4.0 using 1999052009m6

Updated

19 years ago
Status: RESOLVED → REOPENED
Priority: P3 → P1

Comment 17

19 years ago
It also crashes when I move message on Linux (1999-05-20-08m6)
Reopen bug. Change it to P1

here is the stack trace:

#0  0x8890c89 in ?? ()
#1  0x402cdb3b in NS_NewScriptEventListener ()
#2  0x403354b4 in js_GetProperty ()
#3  0x4032948e in js_Interpret ()
#4  0x40327dd0 in js_Invoke ()
#5  0x40327f75 in js_CallFunctionValue ()
#6  0x40312c99 in JS_CallFunctionValue ()
#7  0x402cd640 in nsJSEventListener::HandleEvent ()
#8  0x40962e09 in nsEventListenerManager::HandleEvent ()
#9  0x4078619d in RDFElementImpl::HandleDOMEvent ()
#10 0x407861f8 in RDFElementImpl::HandleDOMEvent ()
#11 0x407861f8 in RDFElementImpl::HandleDOMEvent ()
#12 0x40099a0a in nsMenuItem::DoCommand ()
#13 0x40099841 in nsMenuItem::MenuItemSelected ()
#14 0x4009a566 in menu_item_activate_handler ()
#15 0x80c41f6 in gtk_window_set_default_size ()
#16 0x809ce37 in gtk_signal_connect_object ()
#17 0x809c4be in gtk_signal_connect_object ()
#18 0x809abfa in gtk_selection_data_set ()
#19 0x80bc848 in gtk_widget_size_request ()
#20 0x808b9b5 in gtk_menu_shell_append ()
#21 0x808aeb6 in gtk_menu_shell_append ()
#22 0x80c3fdc in gtk_window_set_default_size ()
#23 0x809c4eb in gtk_signal_connect_object ()
#24 0x809abfa in gtk_selection_data_set ()
#25 0x80bc724 in gtk_widget_size_request ()
#26 0x8085d79 in gtk_get_current_event ()
#27 0x808531a in gtk_main_iteration_do ()
#28 0x80d31ab in gdk_input_add ()
#29 0x80e6130 in g_list_length ()
#30 0x80e65ab in g_list_length ()
#31 0x80e66c5 in g_main_iteration ()
#32 0x8084e2f in gtk_main ()
#33 0x4009281b in nsAppShell::Run ()
#34 0x40018da6 in nsAppShellService::Run ()
#35 0x8051313 in main ()

Updated

19 years ago
Resolution: FIXED → ---

Comment 18

19 years ago
If you'd like the crashing bugs to be entered into a separate bug report, let us
know.  Would like to be fixed for M6 if possible.  Thanks.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 19

19 years ago
Lisa, per your request.  I have opened a crash bug #6823. Should I mark this
Verified?

Comment 20

19 years ago
Lisa, per your request.  I have opened a crash bug #6823. Should I mark this
Verified?

Comment 21

19 years ago
Since Fenella has opened up a new bug, that new bug will track the crashing
problem.  We'll leave this bug 5792 as resolved/fixed then.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 22

19 years ago
RE: linux build (1999-05-25-16 m6) and Win_nt 4.0 (1999-05-25-17 m6)
The move works on win_nt 4.0 and Linux now.
Since we have another bug (6975) to track the mac move problem.  I am going
to verify this bug.  Lisa, if you disagree, please let me know.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.