Crash [@ nsDummyJavaPluginOwner::Destroy] with Java and Silverlight in xul

RESOLVED WORKSFORME

Status

()

Core
DOM
--
critical
RESOLVED WORKSFORME
8 years ago
9 months ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows 7
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

355 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

8 years ago
Created attachment 457717 [details]
testcase

See testcase, which crashes current trunk build.

http://crash-stats.mozilla.com/report/index/5a7206d4-f91a-471d-8b52-cdfa12100715
0  	 	@0x6e697270  	
1 	xul.dll 	nsDummyJavaPluginOwner::Destroy 	dom/base/nsGlobalWindow.cpp:456
2 	xul.dll 	nsGlobalWindow::FreeInnerObjects 	
3 	xul.dll 	nsGlobalWindow::SetNewDocument 	dom/base/nsGlobalWindow.cpp:1970
4 	xul.dll 	DocumentViewerImpl::InitInternal 	layout/base/nsDocumentViewer.cpp:958
5 	xul.dll 	DocumentViewerImpl::Init 	layout/base/nsDocumentViewer.cpp:695
6 	xul.dll 	nsXULDocument::Release 	content/xul/document/src/nsXULDocument.cpp:395
(Reporter)

Updated

8 years ago
Blocks: 559412
http://tinyurl.com/2c34d9n shows 27 crashes on the trunk in this stack, a few of which are probably Martijn's.
(Reporter)

Comment 2

8 years ago
From 14/7 and onwards are probably mine (they also have a short lifetime, normally).
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsDummyJavaPluginOwner::Destroy]

Comment 3

6 years ago
Looks to still appear on recent version of firefox but in low volume.

Comment 4

6 years ago
Martijn, can you still reproduce this with the testcase? We don't see this exact signature any more - the one I was referring to above is a bit different. Not sure if it's now a different bug.
(Reporter)

Comment 5

6 years ago
After a long while, I finally crashed with this stack:
https://crash-stats.mozilla.com/report/index/bp-d4b23cb7-3590-4c23-bf41-917a32111201
0 	xul.dll 	DocumentViewerImpl::SetMinFontSize 	layout/base/nsDocumentViewer.cpp:2864
1 	xul.dll 	nsDocShell::SetupNewViewer 	docshell/base/nsDocShell.cpp:7711
2 	xul.dll 	nsDocShell::Embed 	docshell/base/nsDocShell.cpp:5797
3 	xul.dll 	nsDocShell::CreateContentViewer 	docshell/base/nsDocShell.cpp:7477
4 	xul.dll 	nsDSURIContentListener::DoContent 	docshell/base/nsDSURIContentListener.cpp:147
5 	xul.dll 	nsDocumentOpenInfo::TryContentListener 	uriloader/base/nsURILoader.cpp:709
6 	xul.dll 	nsDocumentOpenInfo::DispatchContent 	uriloader/base/nsURILoader.cpp:406
7 	xul.dll 	nsDocumentOpenInfo::OnStartRequest 	uriloader/base/nsURILoader.cpp:294
8 	xul.dll 	nsBaseChannel::OnStartRequest 	netwerk/base/src/nsBaseChannel.cpp:730
9 	xul.dll 	nsInputStreamPump::OnStateStart 	netwerk/base/src/nsInputStreamPump.cpp:441
10 	xul.dll 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:397
11 	xul.dll 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
12 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:625
13 	nspr4.dll 	PR_Unlock 	nsprpub/pr/src/threads/combined/prulock.c:347
14 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
15 	xul.dll 	_SEH_epilog4 	
16 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
17 	xul.dll 	nsISupportsKey::~nsISupportsKey 	xpcom/ds/nsHashtable.h:253
18 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
19 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:258

This is a different stack than the original one mentioned here, though. And iirc, I filed a different bug about that one, too.

Comment 6

6 years ago
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #5)
> This is a different stack than the original one mentioned here, though. And
> iirc, I filed a different bug about that one, too.

Bug 647500 seems to be about that signature. Does that mean the bug here should be marked resolved in some way?
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) in Firefox (except obsolete Fx 3 & 4).
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.