If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox hangs when right-clicking a file in an Open/Save File dialog.

RESOLVED INVALID

Status

()

Firefox
General
--
critical
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: Luiz, Unassigned)

Tracking

({stackwanted})

3.6 Branch
x86
Windows 7
stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120413])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-BR; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

Seems like firefox crashes every time you right-click a file in any open/save file dialog. It simply shows a 'waiting' cursor and hangs. Force-kill the task to close it.

Reproducible: Always

Steps to Reproduce:
1. Go on File -> Open File...
2. Open a folder where a file can be seen
3. Right-Click the file to open a context menu
Actual Results:  
Firefox hangs.

Expected Results:  
Showed Windows file context-menu.

Windows is Build 7100. Does seems to happens on RC and OEM softwares I tested as well.

Comment 1

7 years ago
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
Keywords: stackwanted

Comment 2

7 years ago
I too experience this problem, making Firefox completely unusable (I use Chrome now). I cannot get a stacktrace with WinDbg since the hang won't occur. I should add that when it hangs, Firefox consumes no CPU, so I'm guessing it's some kind of deadlock issue, which is probably why I can't duplicate the bug with a debugger attached.

Comment 3

7 years ago
you can attach to firefox w/ windbg instead of running firefox from windbg. use file>attach to process or such. the instructions are mostly the same otherwise.

Updated

7 years ago
Version: unspecified → 3.6 Branch
looks like op is not here around, if you can reproduce, feel free to reopen it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Whiteboard: [testday-20120413]
You need to log in before you can comment on or make changes to this bug.