JavaScript Delete button in the inbox frame cannot be clicked in onebox.com accounts

VERIFIED WORKSFORME

Status

()

Core
Event Handling
P3
normal
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Ken Yee, Assigned: joki (gone))

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Sign up for a free mail accouont.
Send yourself a message.
Move your mouse over the Delete button and notice that it doesn't provide a hint
in the status bar like the other buttons do.
Try clicking on Delete button.  Notice that you cannot click it.
Try the similiar Delete button at the bottom (after your msgs) and this one works.

I can't see anything obvious when I look at the HTML by doing a View Source.

Comment 1

17 years ago
Can you add the html as an attachment?
(Reporter)

Comment 2

17 years ago
Created attachment 17971 [details]
This is the inbox page.  Please ignore the comment in the bug about the 2nd delete button.  That shows up if you click on a msg.

Comment 3

17 years ago
Mousing over 'Delete' produces 'Delete Selected Messages' in the status bar for me.

Comment 4

17 years ago
Don't know which build I was using yesterday, but the testcase works for me in
build 2000102620 in WinNT today.
(Reporter)

Comment 5

17 years ago
This is a very weird bug.  It doesn't reproduce itself from the attached .html file.
What you have to do is follow this sequence:
1) shut down all your mozilla windows
2) log onto www.zdnetonebox.com (create an account if you need to before this
and send yourself an email msg)
3) you will see a welcome screen; click the Inbox link on your left
4) you will see your inbox along w/ a bunch of buttons at the top of the msg list
5) mouse over the Delete button along the top of the msg list

If you click a msg link to read a msg, you will also see a Delete button.  This
works.
If you click the Inbox link again, the Delete button in (5) works.
If you reopen www.zdnetonebox.com, it will automatically log you in and bring
you to the welcome screen.  If you click the Inbox link, the Delete button
continues to work.  It's almost like there was an uninitialized variable that
needed to be set.
To reproduce the bug, you have to follow the exact steps above.  I reproduced w/
last night's build of 2000102620 on WinNT4 SP6a.

Comment 6

17 years ago
Confirming bug using WinNT MN6 branch binary 2000102609 
                      and Linux trunk binary 2000102608


Changing OS to "All".I set up an account at the site, logged in, 
clicked on the "Inbox" link. At this page, there are three anchors 
in blue at the top - "Get Mail", "Get External Mail", and "Delete".


When I first visit this Inbox page, only the first two react to mouseovers.
Once I reload the page, e.g. by going Back and Forward, the Delete anchor
reacts to mouseover (by showing "Delete selected messages" in the status bar).


Here is the HTML for the three anchors. They are contained in a table:


<TABLE border=0 valign=top cellpadding=0 cellspacing=1 width=20%>
<TR valign=bottom>
<TD width=3%>
<A href="javascript:doGetMail();" onMouseOver="return hint('Get your new 
email')" onMouseOut="return hint()"><IMG src="/g/but_getmail.gif" alt="Get Mail" 
height="20" hspace="0" vspace="0" border="0" align="left"></A></TD><TD 
width=1%><IMG src="/graphics/blank.gif" width=5></TD>
<TD width=3%>
<A href="folder?u=6827435&r=f5b470d569&folderid=INBOX&msg_action=ge" 
onMouseOver="return hint('Get external mail')" onMouseOut="return hint()"><IMG 
src="/g/but_getexternal.gif" alt="Get External Mail" height="20" hspace="0" 
vspace="0" border="0" align="left"></A></TD><TD width=1%><IMG 
src="/graphics/blank.gif" width=5></TD>
<TD width=3%>
<A href="javascript:doDelete();" onMouseOver="return hint('Delete selected 
messages')" onMouseOut="return hint()"><IMG src="/g/but_delete.gif" height="20" 
hspace="0" vspace="0" border="0" alt="Delete"></A></TD></TR>
</TABLE>



Might this  bug be related to bug 49120? At any rate, 
not a JS Engine issue; reassigning to Event Handling -



For reference, here is the JavaScript function hint() from the HTML:

function hint(s) {
  window.status = (s ? s : '')
  return true
}


However, I cannot find the JavaScript functions doGetMail(), etc.
Can someone help me on this? Where is the included js file???
I couldn't find it anywhere I looked: in any of the frames, nor in 
the parent page itself.
Assignee: rogerl → joki
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Event Handling
Ever confirmed: true
OS: Windows NT → All
QA Contact: pschwartau → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
(Assignee)

Comment 8

17 years ago
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future

Comment 9

17 years ago
reporter are you still seeing this?

Comment 10

17 years ago
This Works For Me in Build 2001061020 in WinNT.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 11

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 12

16 years ago
verified on build 2001-08-14-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.