Moving an app tab does not show the insert pointer in the correct location

VERIFIED FIXED in Firefox 4.0b3

Status

()

defect
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: kbrosnan, Assigned: dao)

Tracking

Trunk
Firefox 4.0b3
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?
in-litmus +

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [AppTabsTestday] [in-litmus-bug-week])

Attachments

(3 attachments)

Create a set of at least 3 app tabs. Drag one of them to arrange. The insertion pointer stays in the gap between app tabs and normal tabs.
Blocks: 578061
Posted patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #460905 - Flags: review?(gavin.sharp)
Comment on attachment 460905 [details] [diff] [review]
patch

Is there a bug on altering the drag feedback while trying to drag non-app-tabs to the app tab area (which won't succeed)?
Attachment #460905 - Flags: review?(gavin.sharp) → review+
(In reply to comment #4)
> Comment on attachment 460905 [details] [diff] [review]
> patch
> 
> Is there a bug on altering the drag feedback while trying to drag non-app-tabs
> to the app tab area (which won't succeed)?

Not yet, and I'm not sure whether we want it to not succeed or transition the tab into an app tab.
Attachment #460905 - Flags: approval2.0?
blocking2.0: --- → final+
Attachment #460905 - Flags: approval2.0?
http://hg.mozilla.org/mozilla-central/rev/b5781cd2d4fc
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b3
Verified fixed with Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b3pre) Gecko/20100802 Minefield/4.0b3pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Litmus testcase added:
https://litmus.mozilla.org/show_test.cgi?id=12793
Flags: in-litmus? → in-litmus+
Whiteboard: [AppTabsTestday] → [AppTabsTestday] [in-litmus-bug-week]
You need to log in before you can comment on or make changes to this bug.