Automated posts to m.d.tree-management for mobile-1.9.2 have pushlog ranges with mismatched repo / revisions

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Quoting a recent post to m.d.tree-management:
SUBJECT: Talos Improvement: Tp4 decrease 47.57% on Nokia n810 mobile-1.9.2


On 07/16/2010 10:44 AM, Nobody wrote:
> Improvement: Tp4 decrease 47.57% on Nokia n810 mobile-1.9.2
>     Previous results:
>         29032.0 from build 20100715122108 of revision 2ed18390992f at 2010-07-15 18:34:00 on maemo-n810-11 run # 0
>     New results:
>         15221.2 from build 20100715122108 of revision 2ed18390992f at 2010-07-16 02:33:32 on maemo-n810-40 run # 0
>     http://mzl.la/a42BZ5
>     http://hg.mozilla.org/mobile-browser/pushloghtml?fromchange=2ed18390992f&tochange=2ed18390992f

That hg link is broken -- the changeset isn't part of that "mobile-browser", so it produces a page with this content:
> An error occurred while processing your request
> unknown revision '2ed18390992f'

A more correct hg link is:
http://hg.mozilla.org/releases/mobile-1.1/pushloghtml?fromchange=2ed18390992f&tochange=2ed18390992f
(note that that's still an empty pushlog range, since fromchane == tochange, but at least it's valid changeset there, as shown by this single-changeset view:
http://hg.mozilla.org/releases/mobile-1.1/rev/2ed18390992f
)
(Reporter)

Comment 1

8 years ago
(In reply to comment #0)
> That hg link is broken -- the changeset isn't part of that "mobile-browser",

er, I meant to say |isn't part of the repository "mobile-browser"|
(Reporter)

Updated

8 years ago
Summary: mobile-1.9.2 posts to m.d.tree-management give pushlog ranges with mismatched repo / revisions → Automated posts to m.d.tree-management for mobile-1.9.2 have pushlog ranges with mismatched repo / revisions

Comment 2

8 years ago
Created attachment 458379 [details] [diff] [review]
mozilla-1.9.2 mobile repo -> mobile-1.1
Attachment #458379 - Flags: review?(catlee)

Comment 3

8 years ago
Created attachment 458381 [details] [diff] [review]
that should be releases/mobile-1.1
Attachment #458379 - Attachment is obsolete: true
Attachment #458381 - Flags: review?(catlee)
Attachment #458379 - Flags: review?(catlee)

Updated

8 years ago
Attachment #458381 - Flags: review?(catlee) → review+

Comment 4

8 years ago
Comment on attachment 458381 [details] [diff] [review]
that should be releases/mobile-1.1

http://hg.mozilla.org/graphs/rev/0b9175ebcae0
Attachment #458381 - Flags: checked-in+

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering

Comment 5

3 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/e048324033d355b238baca00faeb9ff76a1768a6
fix mobile-1.1 regression emails. bug 579508, r=catlee

--HG--
branch : 1.0
You need to log in before you can comment on or make changes to this bug.