Last Comment Bug 579522 - Buy cots for the JS interns
: Buy cots for the JS interns
Status: VERIFIED FIXED
[This bug is not actually a joke.]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: general
:
Mentors:
http://www.flickr.com/photos/sayre/48...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-16 13:53 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2010-07-26 09:32 PDT (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
final+


Attachments
Implements cot (1.18 KB, patch)
2010-07-19 13:50 PDT, Andrew Drake [:adrake]
no flags Details | Diff | Splinter Review
Screenshot that confirms this (143.67 KB, image/jpeg)
2010-07-21 13:40 PDT, Wilson Lee [:kourge]
no flags Details

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2010-07-16 13:53:09 PDT
I have it on good authority that if we buy the JS interns cots they won't leave the office, which will result in us beating V8 faster.
Comment 1 Robert Sayre 2010-07-16 13:59:38 PDT
Approved.
Comment 2 David Anderson [:dvander] 2010-07-19 12:25:03 PDT
on order
Comment 3 Andrew Drake [:adrake] 2010-07-19 13:50:18 PDT
Created attachment 458419 [details] [diff] [review]
Implements cot

Waldo thought this might help.
Comment 4 Zack Weinberg (:zwol) 2010-07-19 14:01:23 PDT
Is this really a good idea?  "Crunch mode" produces bugs and burns people out  -- see e.g. http://archives.igda.org/articles/erobinson_crunch.php
Comment 5 [not reading bugmail] 2010-07-19 14:03:16 PDT
True, but being able to rest does help the mind. :)
Comment 6 Zack Weinberg (:zwol) 2010-07-19 14:07:55 PDT
To paraphrase something said at my SO's old job when someone complained about the hallway lights turning off at two AM: the problem is not the absence of cots; the problem is that the interns should have gone home long before they get too tired to go home.
Comment 7 Chris Leary [:cdleary] (not checking bugmail) 2010-07-19 14:12:16 PDT
(In reply to comment #4)
> Is this really a good idea?  "Crunch mode" produces bugs and burns people out 
> -- see e.g. http://archives.igda.org/articles/erobinson_crunch.php

The thing that I glean from that article is that the interns should be getting seven hours of restful sleep a night in order to fire artillery rounds at hospitals. Can we add weaponry to a PO for cots?
Comment 8 Robert Sayre 2010-07-19 14:33:50 PDT
(In reply to comment #4)
> Is this really a good idea?  "Crunch mode" produces bugs and burns people out 
> -- see e.g. http://archives.igda.org/articles/erobinson_crunch.php

it's only a bad idea if it's done without any humor whatsoever
Comment 9 Andrew Drake [:adrake] 2010-07-19 17:11:56 PDT
Reassigning to default since I don't have a corp card.
Comment 10 Justin Dolske [:Dolske] 2010-07-19 17:23:18 PDT
I think trucker speed would be a more effective solution to the problem.
Comment 11 Andrew Drake [:adrake] 2010-07-19 17:29:36 PDT
Added see also https://bugzilla.mozilla.org/show_bug.cgi?id=578133 .
Comment 12 [not reading bugmail] 2010-07-19 17:32:02 PDT
drinking a bit of v8 might help too.
Comment 13 Kyle Huey [:khuey] (khuey@mozilla.com) 2010-07-19 19:01:21 PDT
(In reply to comment #12)
> drinking a bit of v8 might help too.

Verbotten.  Remember what they work on and who their competition is?
Comment 14 Ryan VanderMeulen [:RyanVM] 2010-07-19 19:03:40 PDT
To beat the enemy, you have to think like the enemy. Combine that with "you are what you eat" ;)
Comment 15 [not reading bugmail] 2010-07-19 19:08:08 PDT
Maybe, v8 juice has plenty of fruits and vegetables, so it could generate high energy.
Comment 16 David Anderson [:dvander] 2010-07-19 19:19:04 PDT
(In reply to comment #15)

Just took your recommendation because there were cans in the office fridge. It tasted like drinking thick, cold, uncooked soup broth. I won't file a bug though since the picture on the front leads me to believe this is intended functionality.
Comment 17 Robert Sayre 2010-07-19 19:25:49 PDT
This bug is full of idle speculation. Data would be much better. For instance: C10999904740719
Comment 18 [not reading bugmail] 2010-07-19 19:56:52 PDT
(In reply to comment #3)
> Created attachment 458419 [details] [diff] [review]
> Implements cot
> 
> Waldo thought this might help.

Can we get some data on this to see if this helps?
Comment 19 Andrew Drake [:adrake] 2010-07-19 21:18:02 PDT
               C10999904740719
-------------------------------------------------
(In reply to comment #3)
> Created attachment 458419 [details] [diff] [review] [details]
> Implements cot
> 
> Waldo thought this might help.

Doesn't appear to have caused cots to appear. Was worth a shot, I guess.
Comment 20 Robert Sayre 2010-07-19 21:23:51 PDT
(In reply to comment #19)
> 
> Doesn't appear to have caused cots to appear. Was worth a shot, I guess.

I'm sorry, I should have been more clear in my software engineering communications. C10999904740719 is only a preliminary result. I will be measuring with more exacting standards over the next few days.
Comment 21 Andrew Drake [:adrake] 2010-07-19 21:46:33 PDT
(In reply to comment #16)
> (In reply to comment #15)
> 
> Just took your recommendation because there were cans in the office fridge. It
> tasted like drinking thick, cold, uncooked soup broth. I won't file a bug
> though since the picture on the front leads me to believe this is intended
> functionality.

So, are we fast yet?
Comment 22 Jo Hermans 2010-07-20 03:59:54 PDT
(In reply to comment #16)
> (In reply to comment #15)
> 
> Just took your recommendation because there were cans in the office fridge. It
> tasted like drinking thick, cold, uncooked soup broth. I won't file a bug
> though since the picture on the front leads me to believe this is intended
> functionality.

You forgot to add the vodka and the Tabasco :-)
Comment 23 Andrew Drake [:adrake] 2010-07-21 13:25:07 PDT
Cots delivered!
Comment 24 Wilson Lee [:kourge] 2010-07-21 13:40:16 PDT
Created attachment 459133 [details]
Screenshot that confirms this
Comment 25 Jo Hermans 2010-07-21 14:22:59 PDT
Reminds me of the time that I worked for the European Commission in Brussels, where we had a fully equipped studio with bed, shower and kitchenette. That was supposed to be for emergency purposes (heavy snow, train strike, picket in front of the building, ...) Also handy if you went out with the colleagues and missed the last train (or was to drunk to find back the station). Or for a good afternoon nap, like I can see in the screenshot.

But often the key was borrowed by various employees and their girlfriends for an hour or so :-) One day, some English journalists heard about it (The Sun I think), and stormed various offices demanding to see "the bed". They never found it :-)
Comment 26 Sean Stangl [:sstangl] 2010-07-21 14:39:32 PDT
Rest assured: we have no girlfriends.
Comment 27 Justin Dolske [:Dolske] 2010-07-21 15:07:35 PDT
(In reply to comment #26)
> Rest assured: we have no girlfriends.

One issue per bug, please -- file a followup for this if you wish.
Comment 28 Jed Leahy 2010-07-26 09:32:09 PDT
where do we make the deposit, I'm serious!  ;)

Note You need to log in before you can comment on or make changes to this bug.