Google Maps URL's Re-Route to Google Maps Mobile

RESOLVED DUPLICATE of bug 573608

Status

RESOLVED DUPLICATE of bug 573608
8 years ago
8 years ago

People

(Reporter: jhill, Unassigned)

Tracking

unspecified
Future
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
When looking at a tab from a home computer on the Firefox Home app, a google map tab will re-route to the google maps mobile webpage and no longer contain your map with directions and such.

To replicate:
1. Open up: http://www.google.com/maps?f=d&source=s_d&saddr=555+East+Middlefield+Road,+Mountain+View,+CA&daddr=4th+and+king,+san+francisco,+ca&hl=en&geocode=FUGpOgIdTFS5-ClzwFcZOLePgDFMIQKfbPflTA%3BFTdsQAIdLWm0-CnPvjPr1n-PgDHn1NxhVzZ0OA&mra=ls&sll=37.570535,-122.251395&sspn=0.582328,1.175537&ie=UTF8&ll=37.587031,-122.236633&spn=0.5822,1.175537&z=10 on a computer
2. Sync Firefox by going to Tools->Sync->Sync Now
3. Open Firefox Home on the iPhone
4. Open the Google Maps (555 middlefield) tab.
5. Note how you are re-routed to the google maps mobile site and your directions did not persist.

When opening a maps url we should do one of the following:
1. Send the map information directly to the maps application on the iPhone
2. Make sure that the maps information (directions, etc) persist when google re-routes to the mobile version of maps
3. Do not allow google to re-route to the mobile version of maps
I just tried to reproduce this. (Using FxHome 1.0.1, if it matters)

It actually works correctly in the embedded viewer, but "View in Safari" has the bad behavior documented above. This is odd, actually, and I thought system open events to http://maps.google.com got hijacked by Maps anyway.

Comment 2

8 years ago
Moving FFHome-related bugs to new component -> Firefox Home
Component: Experimental Clients → Firefox Home
QA Contact: experimental.clients → firefox-home

Updated

8 years ago
Target Milestone: --- → Future

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573608
You need to log in before you can comment on or make changes to this bug.