Status

--
blocker
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: paulc, Assigned: fox2mike)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
Per bug 579592, we need a quick push. SVN tag is:

* SVN tag is:
http://svn.mozilla.org/projects/sumo/tags/1.5/1.5.5.1_20100716

* run htaccess.sh for the fix to take effect

* as always, flush all caches
Stuck in traffic, will need to hold this for a bit unless anyone else is online in IRC.
Assignee: server-ops → dmoore
This will break webtrends on the Kitsune pages!

Paul: there has been work on trunk since 1.5.5, including moving the webtrends JS. You need to copy the last tag and then patch it directly, as well as patching trunk, then push the updated tag.
(Reporter)

Comment 3

8 years ago
Got it. Retagging.
(Reporter)

Comment 4

8 years ago
Thanks James. Trunk is already patched (I tagged off of it). New tag created off of 1.5.5:
https://svn.mozilla.org/projects/sumo/tags/1.5/1.5.5.1_20100716_v2

Derek: please use this instead!
(Assignee)

Comment 5

8 years ago
Alright, I can do this.
Assignee: dmoore → shyam
(Assignee)

Comment 6

8 years ago
Err, no go :

[root@mradm02 support.mozilla.com]# svn info
Path: .
URL: https://svn.mozilla.org/projects/sumo/tags/1.5/1.5.5_r68485_20100608
Repository Root: https://svn.mozilla.org
Repository UUID: 4eb1ac78-321c-0410-a911-ec516a8615a5
Revision: 69410
Node Kind: directory
Schedule: normal
Last Changed Author: jsocol@mozilla.com
Last Changed Rev: 69389
Last Changed Date: 2010-06-23 14:15:22 -0700 (Wed, 23 Jun 2010)

[root@mradm02 support.mozilla.com]# svn switch https://svn.mozilla.org/projects/sumo/tags/1.5/1.5.5.1_20100716_v2
svn: Directory 'webroot/img/webmail' is missing
svn: Directory 'webroot/img/webmail' is missing
(Assignee)

Comment 7

8 years ago
Since this is broken and there is no dev around, I'm bumping it back down to major and re-assigning to server-ops.

If you file blockers on a Friday night, please be around and wait for things to be done before you take off, or refrain from filing blockers.
Assignee: shyam → server-ops
Severity: blocker → major
(Reporter)

Comment 8

8 years ago
You're right. I was around until 8:30 and then I took off for a bit.
(Assignee)

Updated

8 years ago
Assignee: server-ops → shyam
Severity: major → blocker
(Assignee)

Comment 9

8 years ago
This is something on your end. dump should be a link in svn, not a directory.

[root@mradm02 support.mozilla.com]# svn switch https://svn.mozilla.org/projects/sumo/tags/1.5/1.5.5.1_20100716_v2
svn: Expected 'webroot/dump' to be a directory but found a file
svn: Expected 'webroot/dump' to be a directory but found a file

We could fix that and re-tag or I could just push this fix manually and we'll solve the dump/ issue later.
(Assignee)

Comment 10

8 years ago
Manually patched htaccess.dist to have

+# Firefox Home help articles
+RewriteRule ^1/firefox-home/([0-9]+\.[0-9]+[^/]*)/iPhone/([\-a-zA-Z]+)/log-in/?$ /$2/kb/Cannot+log+in+to+Firefox+Home+App [R,NE]


Works now, this needs to be ironed out before the next sumo push.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

8 years ago
Yeah, I still don't get it. This definitely looks like a directory here:
http://viewvc.svn.mozilla.org/vc/projects/sumo/tags/1.5/1.5.5.1_20100716_v2/webroot/dump/

Either way, thanks for the help. We'll need to look into what was different this time, may have to do with my tagging.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 579608
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.