Missing string in errors.properties

RESOLVED FIXED

Status

Cloud Services
General
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: mfinkle, Assigned: fabrice)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

When running Fennec, with Sync built-in, I see a JS error in the console with clean profiles.

JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://services-sync/ext/StringBundle.js :: anonymous :: line 134"  data: no]

With some dump output, I see the following error:

Key: error.login.reason.no_username
Bundle URL: chrome://weave/locale/services/errors.properties

(This key doesn't seem to exist in any properties file, although it looks like it _should_ be in errors.properties)
Hmm, odd... looks like we're looking for that string directly, instead of via getErrorString (which wraps the call and returns "Unknown Error" if the string isn't found).  This is so we can add the strings we care about when we need to, without having to add l10n for every single possible error.
I'd like to get this fixed for Fennec a1 or b1. Not sure how that lines up with your releases.

What is the string value?
Flags: blocking-fx-sync1.5?
(Reporter)

Updated

8 years ago
Duplicate of this bug: 589348
(Assignee)

Comment 4

8 years ago
Created attachment 471155 [details] [diff] [review]
fix

This patch doesn't add the missing string, but uses the correct method cited in comment #1 to display the fallback generic error.

The missing error string is error.login.reason.no_username - it should be added to m-c/services/sync/locales/en-US/error.properties
Assignee: nobody → fabrice
Attachment #471155 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #471155 - Flags: review? → review?(mconnor)
Comment on attachment 471155 [details] [diff] [review]
fix

I don't expect us to _ever_ hit that error, barring epic failure of a client, so I'd rather not add the string.

r=me on this
Attachment #471155 - Flags: review?(mconnor) → review+
(Reporter)

Updated

8 years ago
Keywords: checkin-needed
pushed:
http://hg.mozilla.org/mobile-browser/rev/58a422b67717
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

7 years ago
Whiteboard: [qa-]
(Reporter)

Updated

7 years ago
Flags: blocking-fx-sync1.5?
You need to log in before you can comment on or make changes to this bug.