Firefox 4 killed my Mac with all the flash crashes

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: crazy4laptops, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla (Macintosh; U; Intel Mac OS X 10.6; en-US) Firefox/4b1

Running OS X Snow leopard 10.6.4 on my Macbook Pro, and found a pretty bad problem. (being as detailed as possible)

I do not know if its just a combo of things- managed to crash flash in many ways over the week- youtube, hulu, chatroulette, etc. by dragging out tabs, just going to the site, or trying to click play...

but today, I went to craigslist and FF crashed when I clicked on photo/video, something weird happened (like when a game crashes and you see rapidly flashing elements on your desktop)

To make it clear, the flashing elements were caused by Firefox, not issues with the graphics card. 

and my cursor turned into a little white hand... you can see it if you hover your mouse on the google search/feeling lucky buttons on the google.com homepage
(only the cursor was smaller than the one on google)

Could not command+tab to get to the finder, cmd+option+esc didn't work, cmd+q didn't work, to be frank, nothing worked at all.
So i had to hard reboot, and ever since then, my SL 10.6.4 installation no longer boots, neither does safe mode (starting up by holding the shift key)
the gear will spin for a little while and then it just stops/freezes and there is no more hdd activity.

Reproducible: Sometimes

Steps to Reproduce:
1. make flash crash by dragging out tabs, surfing youtube for a few hours
2. keep crashing flash over the course of a week
3. goto craigslist.com and hold command down to open a listing in a new tab
Actual Results:  
Firefox crashed the entire Mac OS (and reference details above)

Expected Results:  
Opened a new tab on craigslist

Was using the firefox B persona

http://www.getpersonas.com/en-US/persona/16

Running the latest version of flash- 10.1

Running the FF 4b1, the reason for missing Gecko info on the Build ID is that I'm running in OSX leopard to report this bug.
Firefox is a usermode application. It can crash or freeze but it can't crash the OS. A normal application isn't allowed to do that in a modern OS.


Do you run Leopard on the same system or is that a different system ?
That would rule out a hardware issue.

Do you already tried the apple tips here: http://support.apple.com/kb/ts1417 ?
(booting from Disk and using Disk repair)
(Reporter)

Comment 2

8 years ago
Somehow my entire o/s crashed while i was using FF 4, that's all I can say...

Knowing me, I can crash programs & operating systems in ways that make the support teams say that's not supposed to happen or how did you do that? 

but yes, I do run leopard on the same system (dual boot)

I don't have an OS X disk with me, but after a large amount of patience, the thing finally booted back up. I don't know what fixed it or how it started working again, but now I am running in SL and trying to figure out how to crash it again.
It's not only not supposed to happen, it's impossible unless you intent to do that with your code !

After I read the apple document it could be possible that the OS did a file system check after your hard reboot and that can take a while.

There is nothing we can do to fix that in our code. I will mark this wfm but we will reopen if we either get more reports from other users or if there are working steps to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.