4.76-crashes loading any applet

VERIFIED WORKSFORME

Status

P3
critical
VERIFIED WORKSFORME
18 years ago
8 years ago

People

(Reporter: bill+mozilla-bugzilla, Assigned: beard)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/4.76 (Macintosh; U; PPC)
BuildID:    Communicator 4.7.6/MRJ Plugin 1.0b1

Seems to be any applet will cause crash. MRJ 2.2.3



Reproducible: Always
Steps to Reproduce:
1. enable MRJ Plugin
2. point to page with applet	
3. stand back

Actual Results:  crash

Expected Results:  displayed applet


PowerPC unmapped memory exception at 3E71B348 MRJContext::setClipping()+00054
 
  25-Oct-2000 3:21:31 PM (since boot = 6 hours, 26 minutes)
  Current application is ÒNetscape CommunicatorªÓ
  Machine = #510 (PowerMacG3), System $0910, sysu = $01008000
  ROM version $077D, $45F1, $0001 (ROMBase $FFC00000)
  VM is on; paging is currently safe (and it probably isn't VM's fault)
  NIL^ = $68F168F1
  Stack space used = -44888268
 Address 3E71B348 is in VM file-mapped logical memory space
 It is in the CFM fragment ÒMRJPlugin (4.X)Ó at 3E714000
 It is 00007348 bytes from the start of the fragment
  and 000060A8 bytes into a non-writeable code section at 3E7152A0
 PowerPC 740/750 Registers
                         CR0  CR1  CR2  CR3  CR4  CR5  CR6  CR7
  PC  = 3E71B348     CR  0100 0010 0000 0000 0000 1000 0100 1000
  LR  = 3E71B318         <>=O XEVO
  CTR = 3F8BDF48
  MSR = 00000000         SOC Compare Count
  Int = 0            XER 000   01     14                     MQ  = 00000000
  
  R0  = 009C1220     R8  = 00000000      R16 = 00000000      R24 = 00000008
  SP  = 06E7A9F0     R9  = 06A88860      R17 = 00000000      R25 = 00000008
  TOC = 069DF3D0     R10 = 00000000      R18 = 00000000      R26 = 00000001
  R3  = 000072F8     R11 = 0049E6D0      R19 = 00000000      R27 = 065732D4
  R4  = 00000000     R12 = 3E71B11C      R20 = 00000000      R28 = 06029400
  R5  = 00000000     R13 = 00000000      R21 = 05FFA8D4      R29 = 069E48CC
  R6  = 00000000     R14 = 00000000      R22 = 00000003      R30 = 68F168F1
  R7  = 00000000     R15 = 00000000      R23 = 00000001      R31 = 096F6528
 Disassembling PowerPC code from 3E71B320
  MRJContext::setClipping()
     +0002C 3E71B320   cmplwi     r29,0x0000                              | 
281D0000
     +00030 3E71B324   beq        MRJContext::setClipping()+000CC ; 0x3E71B3C0 | 
4182009C
     +00034 3E71B328   lwz        r4,0x003C(r31)                          | 
809F003C
     +00038 3E71B32C   lwz        r3,0x0014(r4)                           | 
80640014
     +0003C 3E71B330   lwz        r0,0x0018(r4)                           | 
80040018
     +00040 3E71B334   stw        r3,0x0038(SP)                           | 
90610038
     +00044 3E71B338   stw        r0,0x003C(SP)                           | 
9001003C
     +00048 3E71B33C   lwz        r3,0x003C(r31)                          | 
807F003C
     +0004C 3E71B340   lwz        r30,0x0000(r3)                          | 
83C30000
     +00050 3E71B344   lhz        r3,0x003A(SP)                           | 
A061003A
     +00054 3E71B348  *lwz        r0,0x0004(r30)                          | 
801E0004
     +00058 3E71B34C   add        r0,r3,r0                                | 
7C030214
     +0005C 3E71B350   sth        r0,0x003A(SP)                           | 
B001003A
     +00060 3E71B354   lhz        r3,0x003E(SP)                           | 
A061003E
     +00064 3E71B358   lwz        r0,0x0004(r30)                          | 
801E0004
     +00068 3E71B35C   add        r0,r3,r0                                | 
7C030214
     +0006C 3E71B360   sth        r0,0x003E(SP)                           | 
B001003E
     +00070 3E71B364   lhz        r3,0x0038(SP)                           | 
A0610038
     +00074 3E71B368   lwz        r0,0x0008(r30)                          | 
801E0008
     +00078 3E71B36C   add        r0,r3,r0                                | 
7C030214

 Displaying resource information:
  >   Map $06011A60, flags $0000, file $026E = MRJPlugin (4.X)
      Map $05EBE258, flags $0000, file $0266 = Netscape Communicatorª
      Map $06011C38, flags $0000, file $0252 = MRJPlugin (4.X)
      Map $0601EA04, flags $0000, file $0462 = Netscape Resources
   +  Map $00003124, flags $FF9A, file $0003 = ¥ROM resources that override 
System¥
    S Map $00003410, flags $FF8D, file $0002 = System
      Map $009CF354, flags $001C, file $02E6 = File Sharing Library
      Map $000F4648, flags $001C, file $01B2 = OpenTpt Remote Access
      Map $000F4704, flags $001C, file $0182 = Open Transport
      Map $004DA688, flags $FF9C, file $01EA = Language Kit Preferences
      Map $00003078, flags $FF94, file $004E = System Resources
      [Skipped $003F maps belonging to font files]
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  3DBA44C8  
  06E7B5E0    PPC  3DBA4620  
  06E7B590    PPC  3E3EE83C  LApplication::Run()+000B8
  06E7B520    PPC  3DFC2728  XP_GetNonGridContext+289D8
  06E7B4C0    PPC  3E378534  LPeriodical::DevoteTimeToRepeaters(const 
EventRecord&)+0004C
  06E7B460    PPC  3DC562D0  CFrontApp::GetApplication()+010D4
  06E7B410    PPC  3DC56A34  CFrontApp::GetApplication()+01838
  06E7B380    PPC  3DC58610  SSL_DataPending+01460
  06E7B330    PPC  3DDD9C8C  NET_CacheConverter+00D18
  06E7B2F0    PPC  3DDB9E14  NET_DeregisterContentTypeConverter+08358
  06E7B2B0    PPC  3DF9A374  XP_GetNonGridContext+00624
  06E7B270    PPC  3DF9A3B4  XP_GetNonGridContext+00664
  06E7B230    PPC  3DCC3B90  SOB_get_error+0818C
  06E7B1F0    PPC  3DF7F370  FE_DefaultDocCharSetID+3A108
  06E7B1B0    PPC  3DF7F620  FE_DefaultDocCharSetID+3A3B8
  06E7B160    PPC  3E0D74B4  XP_Confirm+178D0
  06E7B110    PPC  3DF9A6B4  XP_GetNonGridContext+00964
  06E7B070    PPC  3DCC4034  SOB_get_error+08630
  06E7B010    PPC  3DCEDE28  XP_TempDirName+04504
  06E7AFD0    PPC  3DCBDB00  SOB_get_error+020FC
  06E7AF60    PPC  3DCBE0CC  SOB_get_error+026C8
  06E7AF20    PPC  3DCBE8CC  SOB_get_error+02EC8
  06E7AEA0    PPC  3DCBE8CC  SOB_get_error+02EC8
  06E7AE20    PPC  3DCBE6B0  SOB_get_error+02CAC
  06E7ADA0    PPC  3DDC1918  CFileMgr::FileSetComment(const FSSpec&, const 
CStr255&)+05684
  06E7AD60    PPC  3DDC16FC  CFileMgr::FileSetComment(const FSSpec&, const 
CStr255&)+05468
  06E7AD00    PPC  3DFC3818  XP_GetNonGridContext+29AC8
  06E7ACC0    PPC  3DE0B444  PREF_CopyDefaultCharPref+25910
  06E7AC80    PPC  3E0024D8  CHTMLView::GetWinCSID() const+09F34
  06E7AC40    PPC  3E0025E4  CHTMLView::GetWinCSID() const+0A040
  06E7ABD0    PPC  3DDDF004  FindPluginFolder(FSSpec*, unsigned char)+03D0C
  06E7AB90    PPC  3DDDF114  FindPluginFolder(FSSpec*, unsigned char)+03E1C
  06E7AB50    PPC  3E72EC10  Private_SetWindow(_NPP*, _NPWindow*)+00020
  06E7AB10    PPC  3E73065C  NPP_SetWindow+00070
  06E7AAC0    PPC  3E7172E8  MRJPluginInstance::SetWindow(nsPluginWindow*)+00028
  06E7AA80    PPC  3E71B124  MRJContext::setWindow(nsPluginWindow*)+000BC
 Return addresses on the stack
  Stack Addr  Frame Addr   ISA   Caller
   06E7ADE8                PPC   3DCBDE48 SOB_get_error+02444
   06E7ADE4                68K   05F3351E
   06E7ADB4                68K   05F3351E
   06E7ADA8                68K   3DCBE6B2 SOB_get_error+02CAE
   06E7AD68    06E7AD60    PPC   3DDC1918 CFileMgr::FileSetComment(const FSSpec&, 
const CStr2
55&)+05684
   06E7AD28    06E7AD20    PPC   FFD57C18 DisposeHandle+00028
   06E7AD14                68K   05F3351E
   06E7AD08    06E7AD00    PPC   3DDC16FC CFileMgr::FileSetComment(const FSSpec&, 
const CStr2
55&)+05468
   06E7ACD4                68K   05F3351E
   06E7ACC8    06E7ACC0    PPC   3DFC3818 XP_GetNonGridContext+29AC8
   06E7ACB2                68K   00000A3C
   06E7AC94                68K   05F3351E
   06E7AC8C                68K   06E7ACAE
   06E7AC88    06E7AC80    PPC   3DE0B444 PREF_CopyDefaultCharPref+25910
   06E7AC68    06E7AC60    PPC   3F8A91EC TrimRect+00A30
   06E7AC54                68K   05F3351E
   06E7AC48    06E7AC40    PPC   3E0024D8 CHTMLView::GetWinCSID() const+09F34
   06E7AC1A                68K   00000A3C
   06E7AC08    06E7AC00    PPC   3F96F29C __DisposeHandle+00010
   06E7ABF8                68K   0044BDEE
   06E7ABF4                68K   05F3351E
   06E7ABE4    06E7ABE0    68K   05F3351E
   06E7ABD8    06E7ABD0    PPC   3E0025E4 CHTMLView::GetWinCSID() const+0A040
   06E7ABA8    06E7ABA0    PPC   3E00A288 
CPrefs::GetButtonFontTextResIDs(unsigned short)+053
0C
   06E7AB98    06E7AB90    PPC   3DDDF004 FindPluginFolder(FSSpec*, unsigned 
char)+03D0C
   06E7AB88    06E7AB80    PPC   3E378300 LPeriodical::StartIdling()+00098
   06E7AB64    06E7AB60    68K   05F3351E
   06E7AB58    06E7AB50    PPC   3DDDF114 FindPluginFolder(FSSpec*, unsigned 
char)+03E1C
   06E7AB48    06E7AB40    PPC   3E36EA84 LArray::FetchIndexOf(const void*, 
unsigned long) co
nst+00044
   06E7AB38    06E7AB30    PPC   3E36EC0C LArray::InsertItemsAt(unsigned long, 
long, const vo
id*, unsigned long)+00168
   06E7AB18    06E7AB10    PPC   3E72EC10 Private_SetWindow(_NPP*, _NPWindow*)+
00020
   06E7AAF8    06E7AAF0    PPC   3E36FCC8 LArray::LinearSearch(const void*, 
unsigned long) co
nst+00094
   06E7AAE8    06E7AAE0    PPC   3E36FA24 LArray::StoreNewItems(unsigned long, 
long, const vo
id*, unsigned long)+0004C
   06E7AAC8    06E7AAC0    PPC   3E73065C NPP_SetWindow+00070
   06E7AAB0                68K   06E7AAEE
   06E7AAA8    06E7AAA0    PPC   3E3835B8 LPane::GetMacPort() const+00028
   06E7AA98                68K   3E38EC72 LView::EstablishPort()+00026
   06E7AA88    06E7AA80    PPC   3E7172E8 
MRJPluginInstance::SetWindow(nsPluginWindow*)+00028
   06E7AA6C                68K   008940E4
   06E7AA68    06E7AA60    PPC   3E3835B8 LPane::GetMacPort() const+00028
   06E7AA64    06E7AA60    68K   008940D8
   06E7AA58    06E7AA50    PPC   3E3912B8 LWindow::EstablishPort()+00030
   06E7AA48    06E7AA40    PPC   3E71B124 MRJContext::setWindow(nsPluginWindow*)+
000BC
   06E7AA08    06E7AA00    PPC   FFD5D180 SetEmptyRgn+0001C
 Displaying memory from sp
  06E7A9F0  06E7 AA40 05EC EDE0  07D1 000E 096F 6528  ¥çª@¥ìíà¥Ñ¥¥¥oe(
  06E7AA00  06E7 AA40 4200 0848  FFD5 D184 0000 0100  ¥çª@B¥¥HÿÕÑ„¥¥¥¥
  06E7AA10  06E7 AA50 0003 30A8  06A2 3DD0 05EB E0D0  ¥çªP¥¥0¨¥¢=Ð¥ëàÐ
  06E7AA20  06E7 AA60 05EC EDE0  0093 72F8 009C 1220  ¥çª`¥ìí॓rø¥œ¥ 
  06E7AA30  06E7 AA70 0634 7AB4  0634 7AB4 096F 6528  ¥çªp¥4z´¥4z´¥oe(
  06E7AA40  06E7 AA80 003F DF2C  3E71 B128 0000 0000  ¥çª€¥?ß,>q±(¥¥¥¥
  06E7AA50  06E7 AA90 069D F3D0  3E39 12BC 0000 1002  ¥çª*¥*óÐ>9¥*¥¥¥¥
  06E7AA60  06E7 AAA0 0089 40DC  3E38 35BC 0089 40E6  ¥çª ¥‰@Ü>85*¥‰@æ
 Displaying memory from 0
  00000000  68F1 68F1 FFC1 0000  0093 72F8 0093 FFFF  hñhñÿÁ¥¥¥“rø¥“ÿÿ
  00000010  0093 72F8 0093 72F8  009C 1220 009C 1220  ¥“rø¥“rø¥œ¥ ¥œ¥

Updated

18 years ago
QA Contact: shrir → junruh

Comment 1

18 years ago
Worksforme. Try deleting QFA.shlb and QA.xpt from the components folder, then 
reinstalling everything. Those two files were interfering with java, but have 
been fixed in recent builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
This was a bug filed against the 4.x version of OIJ, not the 6.x version.  No 
QFA.shlb or QA.xpt.

Comment 3

18 years ago
I'll have to mark this bug invalid. Bugzilla is for testing Netscape 6. Please 
enter new bugs for 4.7X in http://help.netscape.com/forms/bug-client.html
Status: RESOLVED → VERIFIED
OK - I've added beard@netscape.com as a CC: since the OIJ project page says to 
file the bugs here.

Comment 5

18 years ago
Reopening
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 6

18 years ago
I can't repeat this crash on my G3/266 desktop machiine. How much memory have you 
got, and is there anything else interesting about your configuration?
Assignee: edburns → beard

Comment 7

18 years ago
If this is not a bug in Netscape6/Mozilla then please remark it invalid.  4.x
does not use OJI and there should be no 4.x bugs filed in Bugzilla.
(Assignee)

Comment 8

18 years ago
Ahem, 4.76 is using OJI in a limited way, so this bug is useful in helping us 
correct any bugs that my be lurking in the OJI plugin.

Comment 9

18 years ago
this applet did not crash 2000103008 os9 g4 for me - it did not display with
correct size though

Comment 10

18 years ago
Putting 4.76 in the summary.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crashes loading any applet → 4.76-crashes loading any applet
This particular problem appears to be resolved in the 1.02 version of OIJ.
(Assignee)

Comment 12

18 years ago
Closing the bug as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 13

18 years ago
Verified.
Status: RESOLVED → VERIFIED
For the sake of completeness: the same bug exists in 110808 and is fixed by 
upgrading the OIJ version.  

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.