Safe Mode: Add-on status is not exposed in Add-ons Manager UI

RESOLVED DUPLICATE of bug 566194

Status

()

defect
RESOLVED DUPLICATE of bug 566194
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; en-US; rv:2.0b2pre) Gecko/20100718 Minefield/4.0b2pre

With bug 575157 fixed we can now start Minefield in Safe Mode with all extensions disabled. Sadly the state is not exposed in the Add-ons Manager UI itself. The UI still shows the default states for extensions as what it gets from the database.
(In reply to comment #0)
> The UI still shows the default states for extensions as what it gets
> from the database.

Isn't that expected? After all, this is the state the addons will be in if we restart without enabling or disabling anything, isn't it? Though maybe there should be a warning somewhere near the top, saying that all addons are currently disabled because we're in Safe Mode.
Bug 566194 is about the status notification shown and not about the add-on entries. I would say lets leave both things independent from each other. Lets update the summary.
Summary: Safe Mode is not exposed to Add-ons Manager UI → Safe Mode: Add-on status is not exposed in Add-ons Manager UI
(In reply to comment #2)
> Isn't that expected? After all, this is the state the addons will be in if we
> restart without enabling or disabling anything, isn't it? Though maybe there

Thinking about that and comparing with Namoroka shows me that you are right. The only visual indicator is really the notification bar.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
No longer depends on: 575157
Resolution: --- → DUPLICATE
Duplicate of bug: 566194
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.