Fix behavior of tab-manipulation keyboard shortcuts

RESOLVED FIXED

Status

Firefox Graveyard
Panorama
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: aza, Assigned: raymondlee)

Tracking

Details

(Reporter)

Description

8 years ago
Firefox has a number of shortcuts meant for tab-manipulation. Unfortunately, the way that we've implemented Tabcandy breaks most of this shortcuts. The following is a list of keyboard shortcuts that we need to fix.

Command/Alt + 1, 2, 3, ..., 9: To switch to the nth tab

Control+Tab/PageDown: Switch to the next tab
Control+Shift+Tab/PageUp: Switch to the previous tab
(Reporter)

Updated

8 years ago
Assignee: nobody → raymond
(Reporter)

Updated

8 years ago
Duplicate of this bug: 579539
(Assignee)

Comment 2

8 years ago
Based on http://support.mozilla.com/en-us/kb/keyboard+shortcuts, I've fixed the following

Switch to the nth tab:
* Windows: Control + number
* Mac: Command + number
* Linux: Alt + number

Switch to the next tab:
* All: Control+Tab/PageDown
* Mac: Command+Opt+Right Arrow 
* Mac: Command+}
Switch to the previous tab:
* All: Control+Shift+Tab/PageUp
* Mac: Command+Opt+Left Arrow
* Mac: Command+{

http://hg.mozilla.org/users/edward.lee_engineering.uiuc.edu/tabcandy-central/rev/7930e73a2b35
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 3

8 years ago
(In reply to comment #2)
> Switch to the nth tab:
> * Windows: Control + number
> * Mac: Command + number
> * Linux: Alt + number
This is only from within tabcandy ui? Aza marked bug 579539 as a dupe of this where the other bug was for cmd-# from outside tabcandy.
(Reporter)

Comment 4

8 years ago
I had meant for all of these to work outside of the tabcandy UI as well. To be honest, I hadn't thought about what it would mean for them to work inside the Tabcandy UI. On reflection, it seems fine that they also work inside of Tabcandy, but the important thing is for them to work correctly when you are inside a group.
(Assignee)

Comment 5

8 years ago
Those works outside of the tabcandy UI for this bug.

Bug 579192 is for inside of Tabcandy.

Comment 6

8 years ago
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.