bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox does not forget a proxy setting when transitioning from "Use system proxy settings" to "No Proxy"

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Maurice David Wörnhard, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

Firefox does not stop using a proxy it picked up from Windows ("Use system proxy settings", set on Windows via GPO or a local agent like Microsoft Threat Management Gateway 2010) even though the user selects "No Proxy" under Tools -> Options -> Advanced -> Network -> Settings.

Reproducible: Always

Steps to Reproduce:
1. Per default, Firefox has the setting "Use system proxy settings" in Tools/Options, register "Advanced", subtab "Network", button "Settings...". Now if Windows get's configured with a proxy (either by GPO, or some local agent like TMG 2010 Client), Firefox also starts using this proxy
2. Change the proxy setting from "Use system proxy settings" to "No proxy" - but Firefox continues to use the proxy. Verify by visiting a site like http://www.heise.de/ip (showing your IP and if you are using a proxy). - A program restart does not help either.
Actual Results:  
Firefox continues using the proxy it picked up from Windows.

Expected Results:  
Firefox should stop using the proxy.

Workaround:

1. Change the proxy setting from "No proxy" to "Auto-detect proxy settings for this network". Now Firefox looses the proxy information.
2. Change the proxy setting back to "No proxy" and now it works.

I tested both with TMG 2010 Agent and with Windows/IE proxy settings deployed via GPO.

Updated

8 years ago
Version: unspecified → 3.6 Branch
tested with 2012/sep/3 nightly
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.