Feedback button does not play well with personas

RESOLVED FIXED

Status

Mozilla Labs Graveyard
Test Pilot
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: Ian Neal, Assigned: andreshm)

Tracking

Bug Flags:
in-testsuite ?
in-litmus +

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Steps to reproduce
1/ Install version of Firefox with feedback button
2/ Install a persona
3/ Look at feedback button

Expected Result
1/ Feedback button should be semi-transparent or keep standard colour for text

Actual Result
1/ Feedback button is solid background colour but has text colour from persona

For example try with Under_Water_Planet persona from www.getpersonas.com

Updated

8 years ago
Component: Themes → Test Pilot
Product: Toolkit → Mozilla Labs
QA Contact: themes → test-pilot
Target Milestone: --- → --

Updated

8 years ago
Flags: in-testsuite?
Flags: in-litmus?
(Assignee)

Comment 1

8 years ago
Created attachment 462542 [details] [diff] [review]
proposed patch

The feedback button text color was forced to be -moz-dialogtext so it doesn't get overwritten by Personas, and also set the text-shadow to none.

Comment 2

8 years ago
Confirmed the fix.  Imported patch into Test Pilot Hg repo in http://hg.mozilla.org/labs/testpilot/rev/52401e265e24

Needs review for inclusion in Firefox 4 beta before we close the bug.
Attachment #462542 - Flags: review?
It's not specifically part of the Feedback subgroups in Litmus. However, with Feedback integrated into beta releases, this sort of thing would be covered in general Lightweight themes test cases.
Flags: in-litmus? → in-litmus+
Attachment #462542 - Flags: review? → review?(dtownsend)
Attachment #462542 - Flags: review?(dtownsend)
Attachment #462542 - Flags: review+
Attachment #462542 - Flags: approval2.0+
Landed: http://hg.mozilla.org/mozilla-central/rev/0e48d8c3533c
Assignee: nobody → andres
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 574461
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.