Status

()

RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Playing the videos on this page http://www.apple.com/antenna/ with trunk on 10.5 causes a great deal of flickering. Safari doesn't have the same problem.

Comment 1

9 years ago
->benwa for investigation: did this start with retained layers?
Assignee: nobody → b56girard
blocking2.0: ? → final+
Keywords: regressionwindow-wanted
Also I'm wondering if the CoreAnimation rendering model is being negotiated by Quicktime. I have heard that there are some issues with CoreAnimation on 10.5.

I don't have a 10.5 machine. Can someone investigate if this was caused by Core Animation or retained layers landing?
(Reporter)

Comment 3

9 years ago
This is also broken in 3.6 nightlies but fixed when you change the user-agent to firefox. It uses a different video player for Firefox perhaps.

3.5 shows the player and then crashes when you give the site an unexpected useragent.
(Reporter)

Comment 4

9 years ago
Since we've had this problem for a long time it probably doesn't block anymore. However, it would still be good to figure out what's going on here.
blocking2.0: final+ → ---
I don't have access to a 10.5 machine at the moment so I'm un-assigning myself.

At this point it would be great to reconfirm this bug.
Assignee: bgirard → nobody
I don't see any flickering in today's mozilla-central nightly, testing
with the main video at http://www.apple.com/antenna/ on OS X 10.5.8.
(Click on "Watch the video" to start the video.)

Do you still see this problem, Jeff?  If so, please provided detailed
information on how to reproduce it.
I couldn't reproduce this issue on Mac OS 10.8 for FF 17 and Latest Nightly (12/12/2012)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.