[D2D] Duplicated/truncated area display after scrolling up and down

RESOLVED DUPLICATE of bug 587508

Status

()

defect
RESOLVED DUPLICATE of bug 587508
9 years ago
9 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre

I enabled DirectWrite and render-mode was set to 6.
When I scroll down an up several times a page, some page areas are truncated and they are replaced by a duplication of the area above.
The area can be a flash video, an image, a text area, ...

This problem is recent as it is not reproducible in FF 4.0 beta 1.

Graphic card : Intel GMA 4500M
Graphic driver version : 8.15.10.1982 (up-to-date)
WDDM model version : WDDM 1.1
DirectX version : DirectX 11

Reproducible: Sometimes
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Reporter

Comment 2

9 years ago
I did some new tests.

From my 07/19 test, I updated :
  Graphic driver : 8.15.10.2181 (up-to-date for Intel, the 07/19 one was up-to-date for Acer and "Window 7 update")
  Flash player   : 10.1.82.76

My first reference video was a video with horizontal and vertical black strips (http://www.youtube.com/watch?v=lBQkOfORlw8).
My second reference video was a HD video with 2:1 format (http://www.youtube.com/watch?v=Hz86TsGx3fc)
My reference image gallery was a vertical displayed HD images (http://www.pikall.com/)
I scrolled up and down several times until a wrong display happened
Here below is my results  :
  FF 4.0 b1 : no problem
  FF 4.0 b2, b3, b4pre 20100816 : some parts of the vertical black strips of video 1 are replaced by the area above (different behavior from the 07/19 one)

So most of the weird behaviors was due to an out-of-date graphic driver.
It remains the video vertical black strip no refresh bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 4

9 years ago
I added a new test with a flash video in a stand-by state (http://www.youtube.com/watch?v=lBQkOfORlw8)

Here below is my updated results :
  FF 4.0 b1 : no problem
  FF 4.0 b2, b3, b4pre 20100816 :
         * some parts of the vertical black strips of playing video 1 are replaced by the area above,
         * the stand-by video has a horizontal strip that is painted with the area above
Reporter

Updated

9 years ago
Blocks: d2d
No longer blocks: dwrite
Summary: Duplicated/truncated area display after scrolling up and down when DirectWrite is enabled → [D2D] Duplicated/truncated area display after scrolling up and down

Comment 6

9 years ago
This applies to Seamonkey too (Gecko/20100907 SeaMonkey/2.1b1pre).
Open http://www.urlesque.com/2010/09/09/keenan-cahill-lipsync-kid/
and scroll.

OS: Win7 64 Bit pro and ult, one machine is:
Phenom + AMD 790gx chipset + AMD Radeon 4890, the other is:
Athlon X2 + AMD 790FX chipset + Nvidia GForce 8400GS
Chipset and Video card drivers are up to date (less than two weeks old).

Both machines show "bit exact" same errors, i.e. same resolution, hit F11, screenshot, compare.

Comment 7

9 years ago
Graphical Error during scroll with flash

Comment 8

9 years ago
about:config
gfx.direct2d.disabled;true

Does not change that error.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587508
You need to log in before you can comment on or make changes to this bug.