Zooming is not working properly and causes artifacts

RESOLVED WORKSFORME

Status

Fennec Graveyard
Panning/Zooming
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Szymon Paluchowski, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; Linux armv7l; rv:2.0b2pre) Gecko/20100720 Namoroka/4.0b2pre Fennec/2.0a1pre

Zooming feature is broken. Can't zoom the page with zooming keys. As well as that, it populates artifacts shown on page.

Reproducible: Always

Steps to Reproduce:
1. Open Fennec 
2. Navigate to http://www.google.com
3. Use CTRL+DOWN shortcut (hold it for a while)
Actual Results:  
Page is not zooming out (or it zooms out only a little). 

As well as zooming out, zooming in doesn't work well too (but a little bit better).

Additionally when I rotate device into portrait mode I see various artifacts. It seems like multiplied page content at various zoom levels placed one on another. It sometimes gets updated properly after a short while, but sometimes not. Looks horrible.

Expected Results:  
Page should be properly zoomed out and it's zoom status should be updated. No artifacts after that should be visible.

Software version
OS: Maemo 5 (1.2009.42-11)
fennec_2.0~a1~20100720010740
(Reporter)

Updated

7 years ago
OS: Other → Maemo
Hardware: Other → ARM
(Reporter)

Comment 1

7 years ago
Created attachment 458612 [details]
Screenshot - artifacts produced
This is due to tile caching which will be removed once layers lands. I'm not sure of the bug id though.
This wfm on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20100111 Namoroka/4.0b10pre Fennec/4.0b4pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.