Closed Bug 580227 Opened 12 years ago Closed 12 years ago

In-tree testpilot extension doesn't register its component

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 4.0b2
Tracking Status
blocking2.0 --- beta2+

People

(Reporter: benjamin, Assigned: benjamin)

References

Details

Attachments

(1 file, 1 obsolete file)

The in-tree testpilot extension hasn't been fixed up for the new XPCOM registration changes and doesn't register components/TestPilot.js

I'm not sure where this code lives originally or whether its already fixed upstream. Who owns the testpilot impl?
Jono does, and he's gone for a month, I think? cc'ing dtownsend. I take it this means that Testpilot just done doesn't work with the new beta? How is it working with nightlies?
Ah, it doesn't actually work, it's just I get the XUL around it and no visible errors.

Bully.
Attached patch Testpilot registration, rev. 1 (obsolete) — Splinter Review
I wrote this patch blind.
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #458654 - Flags: review?(dtownsend)
Comment on attachment 458654 [details] [diff] [review]
Testpilot registration, rev. 1

I want to keep the in-tree version in sync with the Test Pilot extension as much as possible so can you do the extra bit to make this component work in both 1.9.2 and 2.0? Could you also bump the version in the install.rdf to 1.0 and the maxVersion to 4.0b2. I meant to do this with the couple of landings yesterday but forgot about it.

Once we've fixed this on trunk I'll push the same changes upstream.
Attachment #458654 - Flags: review?(dtownsend) → review-
Attachment #458654 - Attachment is obsolete: true
Attachment #458704 - Flags: review?(dtownsend)
Comment on attachment 458704 [details] [diff] [review]
Backwards-compatible change against the labs/testpilot repo, rev. 1

r=me and landed on trunk with the version bumps. We need to clarify the upstream situation as there are fixes there that Jono didn't say he wanted on trunk and fixes on trunk that haven't yet made it there.

http://hg.mozilla.org/mozilla-central/rev/1a63c61cdc6a
Attachment #458704 - Flags: review?(dtownsend) → review+
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b2
Duplicate of this bug: 580196
You need to log in before you can comment on or make changes to this bug.