Geolocation notification does not show requester of location for file:// URIs

RESOLVED DUPLICATE of bug 570004

Status

RESOLVED DUPLICATE of bug 570004
8 years ago
8 years ago

People

(Reporter: philip.chee, Assigned: philip.chee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Assignee)

Description

8 years ago
Port the following bugs:
Bug 510424 Geolocation notification does not show requester of location for file:// URLs
Bug 510565 Geolocation notification does not show requester of location for file:// URIs [fennec]
Bug 510523 Checking "Remember for this site" stops prompt from working on file:// URIs
(Assignee)

Comment 1

8 years ago
Created attachment 458671 [details] [diff] [review]
Patch 1.0 WIP

(From Bug 510565 Comment 2)
> Gavin Sharp wrote on 2009-10-13 18:03:38 PDT
> 
> Comment on attachment 394551 [details] [diff] [review]
> 
> I'd probably use an "instanceof Ci.nsIFileURL" check rather than schemeIs.

Neil, is this better?

> It seems like we should somehow make the user aware that the local file can
> send the location wherever it wants - they might have the expectation that "a
> local file wants to know" implies that their location will be kept locally, and
> that isn't necessarily the case.

+geolocation.fileWantsToKnow=The file %S wants to know your location.

How about "A local file %S wants to send your location to parts unknown" ?
Attachment #458671 - Flags: feedback?(neil)
(Assignee)

Comment 2

8 years ago
c.c. some people on suggestions for better wording.

> +geolocation.fileWantsToKnow=The file %S wants to know your location.

> How about "A local file %S wants to send your location to parts unknown" ?

Comment 3

8 years ago
I think bug 570004 might already include this.
(Assignee)

Comment 4

8 years ago
> I think bug 570004 might already include this.
Oh snap.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570004

Comment 5

8 years ago
Comment on attachment 458671 [details] [diff] [review]
Patch 1.0 WIP

Clearing request on presumably obsolete patch.
Attachment #458671 - Attachment is obsolete: true
Attachment #458671 - Flags: feedback?(neil)
You need to log in before you can comment on or make changes to this bug.