Questions forum caches filter queries so data is not updated evenly

RESOLVED WONTFIX

Status

support.mozilla.org
Questions
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
The Questions app caches each query so they all time out at different points. This leads to uneven data on the forums- where some data is updated and some is not.

1) log in> ask a new question
2) select 'Most Recent'> Click 'All', 'Unsolved', 'No Replies' filters

expected: new question displays in all three filters
actual: new question appears in Unsolved & No Replies, but not All
(Reporter)

Updated

8 years ago
Target Milestone: --- → 2.2
Duplicate of this bug: 578720
(Reporter)

Comment 2

8 years ago
The update delay is quicker now, but it results show immediately for most but take a few minutes for the 'All' filter
Two days later, how prevalent is this? Some delay is OK as long as the question itself is accessible.
(Reporter)

Comment 4

8 years ago
This repro's easily- the question takes at least 2 min to display under 'All' while showing immediately in the other filters. All things considered, 2 min is small enough most people wouldn't notice it unless they were looking- it shows more as the user is taken back to the forum after asking a question and the 'All' filter shows by default.
Ricky is about to land a patch that will make people confirm questions, anyway, which makes me think we can ignore 2 minutes.

Things might get a little better when we land that patch, actually, or when we move to a Redis/Memcache hybrid for caching, but for now there's not much we can, or need to, I think, do.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.