Toolbar customization reverts to default when closing window in Firefox 4.0b1 and 4.0b2pre, when Firefox Sync 1.4.1 and/or Aza Raskin's TabCandy installed and enabled.

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: pwizla, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; fr; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; fr; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre

Everytime I close a window, toolbar customization is 'lost' (i.e resetted to default customization).
My customization consists in removing the search bar and adding the activity indicator at the right of the awesome/address bar.

I have to do this for all newly opened window because this customization is resetted to default *EACH TIME* I close a window.

Reproducible: Always

Steps to Reproduce:
1. Right-click somewhere in between address bar and search bar, and choose "Customize..." in the pop-up menu.
2. Perform some customizations by dragging-and-dropping elements to add them to or remove them from the existing toolbars.
3. Close the window in which customization was performed.
4. Open a new window.
Actual Results:  
When the new window opens, toolbar customization is reset to defaults.

Expected Results:  
Toolbar customization persists.

If you restart Firefox, with no surprise (because a restart closes the current window and opens a new one), this bug happens too.


This happens in every nightly build I used since the first release of Firefox 4.0b2pre and ALSO happens in the "official" Firefox 4.0b1 release, both on my iMac and on my MacBook, both running the same operating system (Mac OS X 10.6.4).


Though disabling or even uninstalling all add-ons does not solve the problem, which let me think that this bug is not related to any add-on I use, I give you below the list of add-ons I have installed :

(add-ons marked with *** are disabled because not compatible with my current version of Firefox, but left installed in my current config)

Mozilla Labs Team : Account Manager 0.0.13
*** Adblock Plus 1.2.1 
*** Add-Art 0.8.52 
Mozilla Labs Team : Contacts 0.3.2
*** The feedly team : feedly
*** Sam Gross : Firefox PDF Plugin for Mac OS X 1.1.3
Mozilla : Firefox Sync 1.4.1
*** zeniko : Fission 1.0.9
LastPass Dev Team : LastPass 1.69.1
*** Nate Weiner : Read It Later 2.0.6
*** Jason Barnabe (np) : Stylish 1.0.9
Bernd Adler : Tab Focus 1.0.7
Aza Raskin : TabCandy 0.4.1
Mozilla Corporation : Ubiquity 0.6
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Summary: Toolbar customization lost when closing Firefox 4.0b2pre windows. → Toolbar customization revert to default when closing window in Firefox 4.0b1 and 4.0b2pre.
(Reporter)

Updated

8 years ago
Severity: major → normal
Summary: Toolbar customization revert to default when closing window in Firefox 4.0b1 and 4.0b2pre. → Toolbar customization revert to default when closing window in Firefox 4.0b1 and 4.0b2pre, when Firefox Sync 1.4.1 and/or Aza Raskin's TabCandy installed and enabled.
(Reporter)

Comment 1

8 years ago
After having performed another 'intense' testing of every add-on I have, separately, it appears that :

The described bug (toolbar customization reverted to default) only happens when : 
Firefox Sync 1.4.1 is installed AND activated
or Aza Raskin's TabCandy 0.4.1 is installed AND activated.

If I disable both above-mentioned add-ons (Sync and TabCandy), and restart Firefox, my customization is back (in my case, the search bar is removed and an activity indicator is added).
When one of these two add-ons is installed, bugs happens again (upon restart or open new windows, toolbars are back to defaults).

Comment 2

8 years ago
I can confirm this issue happens which Firefox Sync is enabled on 4.0b1. It doesn't seem to be an issue with syncing itself, as I disabled syncing preferences and toolbars were still reset.

Also, notice that 1) when restarting Firefox, the first window doesn't contain the Feedback button, though new windows do and 2) when customizing the buttons of that initial window, no buttons from extensions are available to choose from.

I only have this issue on OS X, my install of 4.0b1 on Windows works fine with the Firefox Sync extension installed and enabled.
(Reporter)

Comment 3

8 years ago
Thanks for your precisions Andrew.
I second your reported bugs :
The apparition of 'Feedback' button and/or other add-ons buttons is erratic. In my case, I can not precisely define when, but sometimes they don't appear in the toolbar, and sometimes they even are not present in the toolbar customization panel, as Andrew described.
(Reporter)

Comment 4

8 years ago
I've just performed a fresh install of Firefox 4.0b1 and Minefield 4.0b2pre and now it appears this happens again ONLY in case of a restart after I install an add-on (whatever add-on it is, Firefox Sync or not).

I really performed a completely fresh install. I indeed deleted all of these files (I don't fear losing any bookmarks/history data, thanks to Firefox Sync ! Thanks guys, btw, about Sync, it is a wonderful addon/feature) :

- the entire ~/Library/Application Support/Firefox folder
- the following preference files : org.mozilla.firefox.plist, org.mozilla.crashreporter.plist and org.mozilla.minefield.plist (located in my ~/Library/Preferences folder)
- the Mozilla folder in ~/Library/Application Support

I also found some of the above-described files and/or folders in the 'general' /Library/Application Support folder (the one at the top level of my hard disk drive volume, shared by all users on my Mac) and deleted them.

So, you got it : complete fresh install of Firefox / Minefield.
And the bug still happens.
(Reporter)

Updated

8 years ago
Summary: Toolbar customization revert to default when closing window in Firefox 4.0b1 and 4.0b2pre, when Firefox Sync 1.4.1 and/or Aza Raskin's TabCandy installed and enabled. → Toolbar customization reverts to default when closing window in Firefox 4.0b1 and 4.0b2pre, when Firefox Sync 1.4.1 and/or Aza Raskin's TabCandy installed and enabled.
(Reporter)

Comment 5

8 years ago
The problem does not occur with the latest Firefox Sync update (v1.4.2).
Since TabCandy is in alpha, I'm not going to consider 'collateral' conflicts between TabCandy and Firefox toolbars customization.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.