Test Pilot study code jar file cache not world-readable

RESOLVED WONTFIX

Status

Mozilla Labs Graveyard
Test Pilot
P2
normal
RESOLVED WONTFIX
8 years ago
2 years ago

People

(Reporter: Jinghua zhang, Unassigned)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: extension-core, code-storage)

(Reporter)

Description

8 years ago
I am a Mozilla Labs Test Pilot, and a recent backup failed. The usual
script warning message appears, but I am aware of that issue. What is
strange, is that I do not get the results page that has appeared in
the past. Instead FEBE crashes with an error. This is the text of the
error message:

[code][Exception... "Component returned failure code: 0x80520015
(NS_ERROR_FILE_ACCESS_DENIED)
<style>color: black;font-size: 8pt;</
style>[nsIZipWriter.addEntryFile]"  nsresult: "0x80520015
(NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS
<style>color: black;font-size: 8pt;</style>frame :: chrome://febe/content/febeZip.js
:: anonymous :: line 83"  data: no]
<style>color: red;font-size: 12pt;</style>Error adding
TestPilotExperimentFiles/base_classes-91.jar to zip archive[/code]

I am using FEBE version 6.3.3.2 on Firefox 3.6.6 with Ubuntu Lucid as
the O/S. Please note this: [b]Error adding TestPilotExperimentFiles/
base_classes-91.jar to zip archive[/b]

I wondered why FEBE should fail on this folder, and after I examined
that folder, I think I know why. Notice the permissions of the files:

[code]
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 06:21 base_classes-10.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 07:31 base_classes-11.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 08:24 base_classes-12.jar
.......
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 06:21 basic-survey-10.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 07:31 basic-survey-11.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 08:24 basic-survey-12.jar
.......
0 ---x--x--T 1 fatboy fatboy 0 2010-06-22 10:42 menu-item-usage-10.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-22 14:15 menu-item-usage-11.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-22 18:02 menu-item-usage-12.jar
.......
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 06:21 toolbar-study-10.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 07:31 toolbar-study-11.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 08:24 toolbar-study-12.jar
.......
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 08:27 week_life-10.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 08:28 week_life-11.jar
0 ---x--x--T 1 fatboy fatboy 0 2010-06-19 10:41 week_life-12.jar
.......
[/code]

The `.......` means that there are many more of these files, I left
them out for brevity. [b]Note that all of these files do not allow
read or write operations[/b]

Updated

8 years ago
Priority: -- → P2
Summary: Test Pilot files causes FEBE to crash → Test Pilot study code jar file cache not world-readable
Whiteboard: extension-core, code-storage
Target Milestone: -- → 1.2
(Reporter)

Updated

8 years ago
Duplicate of this bug: 584359
(Reporter)

Updated

7 years ago
Target Milestone: 1.2 → 1.3
(Assignee)

Updated

2 years ago
Product: Mozilla Labs → Mozilla Labs Graveyard
decommissioned
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.