If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[OOOP] plugin process should be properly named

RESOLVED FIXED in mozilla2.0b3

Status

()

Core
IPC
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: d.a., Assigned: Away for a while)

Tracking

Trunk
mozilla2.0b3
All
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

639 bytes, patch
Benjamin Smedberg
: review+
beltzner
: approval2.0+
Details | Diff | Splinter Review
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2pre) Gecko/20100720 Minefield/4.0b2pre
Build Identifier: 

With the landing of bug 557225 the plugin process shows up as Minefield Software Update as defined in InfoPlist.strings in plugin-process.app/Contents/Resources/English.lproj. This should be changed to say that it is the plugin process.

Reproducible: Always
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 557225
Nominating to get this on the radar since it could be potentially very confusing.
blocking2.0: --- → ?

Comment 2

7 years ago
Not saying we shouldn't fix this, but why would this matter to anybody but the most hard-core hackers? You can't get to this bundle from the Finder, and it doesn't show up in the dock, so AFAICT it's basically an invisible string.
(In reply to comment #2)
> Not saying we shouldn't fix this, but why would this matter to anybody but the
> most hard-core hackers? You can't get to this bundle from the Finder, and it
> doesn't show up in the dock, so AFAICT it's basically an invisible string.

It shows up in Activity Monitor where people will look to check on processor and memory usage.  That's where I saw it today and I thought that the updater had an issue so I quit Minefield and restarted only to find it reappear.  Eventually I found this bug and realized that the process had nothing to do with the updater and was just the name of the plugin container.
It's just this string right here:
http://mxr.mozilla.org/mozilla-central/source/ipc/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings.in

I thought I fixed that in my patch, but I guess it must have slipped by.
(Assignee)

Comment 5

7 years ago
Created attachment 459022 [details] [diff] [review]
Patch (v1)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #459022 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #459022 - Flags: review? → review?(benjamin)

Updated

7 years ago
Attachment #459022 - Flags: review?(benjamin) → review+
(Assignee)

Updated

7 years ago
Attachment #459022 - Flags: approval2.0?
Comment on attachment 459022 [details] [diff] [review]
Patch (v1)

a=beltzner
Attachment #459022 - Flags: approval2.0? → approval2.0+
blocking2.0: ? → final+
(Assignee)

Comment 7

7 years ago
http://hg.mozilla.org/mozilla-central/rev/bbb4fcc2b012
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b3
Duplicate of this bug: 580791
You need to log in before you can comment on or make changes to this bug.