Text of a selected message or folder isn't centered/aligned with its highlight bar

RESOLVED FIXED in Thunderbird 17.0

Status

Thunderbird
Theme
--
trivial
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Karel Koubek, Assigned: Paenglab)

Tracking

({polish, regression, ux-consistency})

unspecified
Thunderbird 17.0
x86
Windows XP
polish, regression, ux-consistency
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.7) Gecko/20100713 Thunderbird/3.1.1

The text of a selected message or folder isn't centered with its highlight bar, should be positioned about 1-2px higher, see attached screenshots. The icons seem to be positioned fine.

This slight visual glitch is a regression from Thunderbird 2.x, where the text is centered fine.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
Created attachment 458845 [details]
Misaligned text highlight
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, regression, ux-consistency

Updated

6 years ago
Component: Folder and Message Lists → Theme
QA Contact: folders-message-lists → theme
(Assignee)

Comment 2

5 years ago
Created attachment 651740 [details] [diff] [review]
patch

Giving -moz-tree-cell-text a padding-bottom of 2px centers the text. On Win7 under default themes removing it again lets the text still centered on Aero and Basic.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #651740 - Flags: ui-review?(nisses.mail)
Attachment #651740 - Flags: review?(nisses.mail)
Comment on attachment 651740 [details] [diff] [review]
patch

looks good ui-wise
Attachment #651740 - Flags: ui-review?(nisses.mail) → ui-review+
Comment on attachment 651740 [details] [diff] [review]
patch

I was a bit torn over padding-bottom: auto; in messenger-aero.css, but since it's supposed to override the one in messenger.css, I think it makes sense.
Attachment #651740 - Flags: review?(nisses.mail) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/ce6fbd594079
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0

Comment 6

4 years ago
I filed Bug 820306 because of the warning generated by padding-bottom:auto. Isn't that an invalid value for a <padding-width>-type?

Updated

4 years ago
Depends on: 820306
You need to log in before you can comment on or make changes to this bug.