main content area empty

RESOLVED WORKSFORME

Status

()

Core
Layout
P1
critical
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: buster, Assigned: Arun Ranganathan)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [netcenter] WEBPAGE IS BUGGY, NOT MOZILLA., URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
using 10/24 commercial build on WinNT.
open url
there's a sidebar on the left of the page that displays correctly
but the main content area to the right is empty.
(Reporter)

Comment 1

17 years ago
looks like a parser problem.  If you remove the 	
<![CDATA[

from the test case I'm about to attach, the rest of the page shows up correctly.
The content model for this test case is:

html@024AD238 refcount=6<
  head@024AD148 refcount=2<
  >
  body@024744A8 refcount=3<
    Text@024A4B20 refcount=3<\n>
    table@024A9F68 width=438 border=1 refcount=7<
      tbody@024ADF28 refcount=3<
        tr@024AF208 refcount=3<
          Text@024AF190 refcount=2<\n  >
          td@024AF09C width=7 bgcolor=#3266cc refcount=4<
            Text@024AC160 refcount=3<cell1>
          >
          Text@024A9840 refcount=2<\n  >
          td@024A97DC refcount=4<
            Text@024A9760 refcount=3<\n\t>
            table@024A96F8 cellpadding=0 cellspacing=0 border=1 refcount=4<
              Text@024A8860 refcount=2<\n\t>

Notice that the final table has only a text element as a child.
Assignee: buster → rickg
Priority: P3 → P1
(Reporter)

Comment 2

17 years ago
Created attachment 18034 [details]
small test case.  remove the illegal content and the page lays out correctly
(Reporter)

Comment 3

17 years ago
nominating for rtm, critical page on Netscape home page.  cc-ing lchiang and
ekrock in case we need a Netcenter contact to fix up the broken HTML source.
Keywords: 4xp, rtm

Comment 4

17 years ago
I'll look into this bug.
Assignee: rickg → harishd

Comment 5

17 years ago
It looks like we are doing exactly what they had asked for. That is, the content
of the inner table to be CDATA. Isn't it?  I don't think Nav. 4.x even supports
"<![[CDATA" and therefore is getting ignored. IMO, we should probably evangelize
this bug than fixing the problem at our end. Comments?
Status: NEW → ASSIGNED

Comment 6

17 years ago
if you are working on this, pls put rtm need info.
Whiteboard: [rtm need info]

Comment 7

17 years ago
Lisa, I'm not going to work on this. This is something that definitely needs
evangelism.  In other words, mozilla is not doing anything wrong ;-)

Comment 8

17 years ago
Ok!  I will try to find a Netcenter owner to take care of this then.

Greggl: you've helped once before :-) Do you know who at Netcenter is
responsible for this page? Thanks.
Keywords: netcenter

Comment 9

17 years ago
Gregg suggested contacting Lee Watters at Netcenter.  lwatters is no a Bugzilla
user so I will follow up with him via email.
chrisn, we need a confirmed Netcenter owner for this bug.

Comment 11

17 years ago
Re-assigning this to lchiang as she is following up with lwatters.
Assignee: harishd → lchiang
Status: ASSIGNED → NEW

Comment 12

17 years ago
Why is this still on the RTM radar?
Whiteboard: [rtm need info] → [rtm need info] WEBPAGE IS BUGGY, NOT MOZILLA.

Comment 13

17 years ago
mark rtm-.   Gregg - do you know if Lee has worked on this yet?
Whiteboard: [rtm need info] WEBPAGE IS BUGGY, NOT MOZILLA. → [rtm-] WEBPAGE IS BUGGY, NOT MOZILLA.
Just talked to Lee, lots of people working on this.  Lee is going to follow up 
with Lisa directly.

Comment 15

17 years ago
have not hear from lee yet.
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase

Comment 17

17 years ago
Any word on this?  The site still isn't displayed in 6.0, but at least there's 
an error message now.
Keywords: rtm
OS: Windows NT → All
Hardware: PC → All
Whiteboard: [rtm-] WEBPAGE IS BUGGY, NOT MOZILLA. → WEBPAGE IS BUGGY, NOT MOZILLA.

Comment 18

17 years ago
Reassigning to chrisn.
Assignee: lchiang → chrisn

Comment 19

17 years ago
Assigning to Arun - owner of all things EA. This is in progress.

Comment 20

17 years ago
finishing reassignment
Assignee: chrisn → aruner
Keywords: netcenter
Whiteboard: WEBPAGE IS BUGGY, NOT MOZILLA. → [netcenter] WEBPAGE IS BUGGY, NOT MOZILLA.

Comment 21

16 years ago
testcase seems to render fine with 2001091305

No movement on this since 2000-11-04. Are we now doing the ideal thing in quirks?

Comment 22

16 years ago
testcase still renders fine on a current linux cvs build too.
Is this still a bug?

Comment 23

16 years ago
WFM. Build ID: 2001 11 15 03. Windows 2000.

Comment 24

16 years ago
WFM and for the three people before me too, obviously.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.