Mail server login name MAY differ from users name!

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: ritchey.mulhollem, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: 

My mail server user name could be BOB.   But my email address might be stupid@biteme.com  Thunderbird does NOT take this into consideration and tries to log into the mail server as "STUPID", but the proper user name is "BOB".

Server login is not always the users email address!!!!  

Outlook Express does NOT have this problem.

Reproducible: Always
You can configure the mail server address, the used username and password for the login and the email adress that this account represents.

I don't understand your problem.
(Reporter)

Comment 2

8 years ago
If you would like, I can set up a demo account on my mail server and let you experience first hand the frustration I have?

The problem is actually quite simple and is easy to fix.

As an example, let's say I enter an email address of "rthawkcom@yahoo.com", during an initial setup.  Thunderbird will attempt to log into the mail server with the user name "rthawkcom".  It NEVER asks for the user name of the mail server.  It just grabs the first part of the email address and blindly tries to log in with it! 

The only way to correct this problem, is to go into the manual configuration and change the user name.  As an example, I change it to "hawk". This creates yet another problem.  When you change the user name used to log into the mail server with, it will then CHANGE YOUR EMAIL ADDERSS TO MATCH!!  I couldn't believe it!!  It changed my email address to "hawk@yahoo.com" (as an example).  I then had to change it back to "rthawkcom@yahoo.com" and then FINALLY it worked!!

In summary.  The system needs to ASK you what your mail server user name is.  It cannot just assume it is the same as the first part of your email address.

Comment 3

8 years ago
Can't you just click the "edit" button and change the username?
(Reporter)

Comment 4

8 years ago
Yes, you can.... and then it changes your email address to match, thereby giving you the wrong email address.

Comment 5

8 years ago
Ah, so the actual bug is:

Editing the username in autoconfig wizard changes the identity e-mail address as well?
(Reporter)

Comment 6

8 years ago
Yes, this would be a second bug.

However.  If you had the option of putting in a mail server user name, separate from your email address, you would never see this bug.

identity email address != mail server username

Comment 7

8 years ago
Clicking edit and changing the username field should only be allowing you to edit the server user name, not the e-mail address. The field says "username", after all. You've already specified the e-mail address in the first screen. At least, that's how I think it should work. If you get your e-mail address wrong, I think you need to go the "start over" route...

Comment 8

8 years ago
Bryan, thoughts?

Comment 9

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100825 Thunderbird/3.1.3

Clicking edit and changing the username field changes only imap username - not SMTP. I have to go in outgoing server properties and change username there too.

Comment 10

7 years ago
(In reply to David :Bienvenu from comment #8)
> Bryan, thoughts?

redirect to Blake, et al :)
Component: Mail Window Front End → Account Manager
QA Contact: front-end → account-manager

Comment 11

7 years ago
This would need proper steps to reproduce. I am not sure this is talking about the accoun Wizard or the accout Manager or what.
(Reporter)

Comment 12

7 years ago
Are you serious!?  Do you people not understand how email servers authenticate?

There is NO OPTION in the account manager to enter the email servers authentication name!!!  Your program simply takes the name off the email address and attempts to log on using that name!!  THIS IS WRONG!!  YOU CANNOT DO THAT!!!

Hell, even Microsoft has an option to use a different authentication name!  I don't know how to explain this any clearer to you!  

EMAIL SERVER LOG ON NAME IS NOT ALWAYS THE USERS EMAIL ADDRESS NAME!!!! 

Two years and you can't even confirm this is a bug!!  I GIVE UP!!!

Comment 13

7 years ago
This works for me on trunk.

1) Input name/email
2) Click "Continue"
3) Click "Manual Config"
4) Change username (which doesn't affect the email address at all)
5) Click "Create Account"
(Reporter)

Comment 14

7 years ago
Finally!  A way to configure the server settings!

Yes, it is confirmed working.

THANK YOU!!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.