bugzilla searches take forever (or never complete)

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
blocker
RESOLVED FIXED
8 years ago
3 years ago

People

(Reporter: gal, Assigned: justdave)

Tracking

Details

Comment hidden (empty)
known problem, been discussing it on #bmo for the last couple hours.
Assignee: server-ops → justdave
Severity: normal → blocker
databases are buried due to additional load from the release and related queries, and the load balancer hasn't been cooperating trying to get traffic sent to additional database servers.
This happens for me only from the quicksearch box for some reason.  Idk if that's luck or an actual symptom.
yeah, actual symptom.  If you're logged in, the quicksearch is almost the only thing that hits the slave DBs, everything else goes to the master.  If you weren't logged in, you'd be getting lagged everywhere.

Should be resolved now.  The problem with the load balancer turned out to be something stupid...  Bugzilla was moved a long time ago into a different netblock, and we still had a virtual server defined in the load balancer for the old one in addition to the new one.  And guess which one I was editing and pulling my hair out trying to figure out why the changes weren't working... :|

The old one's been deleted now, so the current one is the only one there, and we seem to be keeping up fine with 5 databases in the pool now instead of 3.
The real solution of course is getting enough RAM on the database servers for a real innodb_buffer_pool.  RAM's been on order for a few days already because we'd already noticed that.  Can never get here soon enough of course :|
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
This is definitely not fixed. My searches still take forever.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 7

8 years ago
Please wait while your bugs are retrieved.
OK

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, bugzilla-admin@mozilla.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Unrelated, actually :(  a search engine spider decided it would be fun to get stuck in a loop loading the same page over and over several dozen times per second.  I just blocked the IP, should be recovering in a few minutes.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.