Open Bug 580564 Opened 12 years ago Updated 11 years ago

Alt + Space bar, "Restore" wont restore when Firefox is in full screen mode.

Categories

(Core :: Widget: Win32, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

REOPENED

People

(Reporter: BijuMailList, Unassigned)

References

Details

(Keywords: access, regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; Windows NT 6.0; en-US; rv:2.0b2pre) 
Gecko/20100714 Minefield/4.0b2pre

When in full screen mode,  pressing Alt + Space bar then selecting  "Restore" wont make Firefox come out of full screen mode.

Steps:-
1. Start Firefox
2. Go fullscreen mode
3. Press Alt + Space bar 
4. Select "Restore" from the control box menu.

Result:-
Nothing happence

Expected:-
Firefox should end fullscreen mode
Keywords: access
This seems to be new - it doesn't occur in Firefox 3.6.7
Duplicate of this bug: 580599
Component: Shell Integration → Widget: Win32
Product: Firefox → Core
QA Contact: shell.integration → win32
Attached patch fixSplinter Review
Sorry Neil, two in a row. This one is pretty simple though. It's built and tested on top of the patch in bug 632748.
Assignee: nobody → jmathies
Attachment #535445 - Flags: review?(neil)
Comment on attachment 535445 [details] [diff] [review]
fix

While I can see the point of the nsWindow changes, are the nsWebShellWindow changes relevant, and if so, how?
(In reply to comment #5)
> Comment on attachment 535445 [details] [diff] [review] [review]
> fix
> 
> While I can see the point of the nsWindow changes, are the nsWebShellWindow
> changes relevant, and if so, how?

We currently notify the global window from widget when we go into full screen, but we don't notify when we exit. Normally we exit via the DOM but in this case, widget is initiating the change, so we have let the DOM know.

nsGlobalWindow fires a 'fullscreen' event in response to this:
http://mxr.mozilla.org/mozilla-central/source/dom/base/nsGlobalWindow.cpp#4330
Comment on attachment 535445 [details] [diff] [review]
fix

Aha, makes sense now, thanks.
Attachment #535445 - Flags: review?(neil) → review+
http://hg.mozilla.org/mozilla-central/rev/dc1077c09540
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Depends on: 663586
backed out due to regression bug 663586:
http://hg.mozilla.org/mozilla-central/rev/854df0c7239e
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #535445 - Flags: checkin-
Keywords: regression
Assignee: jmathies → nobody
You need to log in before you can comment on or make changes to this bug.