subject not displayed for message which has got the subject header

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: hawran.diskuse, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.10) Gecko/20100512 Lightning/1.0b1 Thunderbird/3.0.5 - Build ID: 20100512121502

There is not a Subject shown for a message, however the message has got the subject, see the screenshot attached, please.

From the message's source:
-----------------
Subject: =?iso-8859-2?Q?P=E1r=20link=F9=20ohledn=EC=20prepaidu?=
Content-Type: text/plain; charset="UTF-8"; format=flowed
Content-Transfer-Encoding: 7bit
-----------------

I'd say it's related somehow with the issue: https://bugzilla.mozilla.org/show_bug.cgi?id=555693


Reproducible: Couldn't Reproduce

Actual Results:  
No subject visible for that particular message.

Expected Results:  
A visible subject.

uname -a
Linux ... 2.6.31.12-for-vmplayer-1-0-x #1 SMP Sun Jun 13 16:23:04 CEST 2010 i686 GNU/Linux

Ubuntu 9.10 (Karmic Koala)

gnome-about --version
GNOME gnome-about 2.28.1
(Reporter)

Comment 1

8 years ago
Created attachment 458968 [details]
No subject visible

Updated

8 years ago
Whiteboard: dupme
What happens if you rebuild the index on that folder ?
(Reporter)

Comment 3

8 years ago
nothing
I'm running out of ideas , anyone ?

Comment 6

8 years ago
Message with that subject displays fine for me on the trunk - have you changed any of the charset settings?

Comment 7

7 years ago
I've had this problem since Thunderbird 5, but only with emails received from my autoresponder software.

The only thing I can think of is that there is an extra carriage return between the to: and subject: field in the email source.

Screenshot:

http://files.dragonrising.com/alex/screenshot2.jpg
(In reply to Alex Kent from comment #7)
> I've had this problem since Thunderbird 5, but only with emails received
> from my autoresponder software.
> 
> The only thing I can think of is that there is an extra carriage return
> between the to: and subject: field in the email source.

This clearly breaks RFC822, where the separation between the headers of an email and the body is achieved thru a empty line. The extra CR is that blank line.

Comment 9

7 years ago
Indeed, and after the autoresponder vendor fixed their software the subject line began showing again. It's interesting though, how different parts of Thunderbird process the subject line differently. The message pane is more forgiving in this area than the message list.

Comment 10

7 years ago
Hello,
i have the same problem as Alex Kent with his screenshot: http://files.dragonrising.com/alex/screenshot2.jpg

but in other clients (like Outlook 2003 or Webmail) i have the missed subject line!

here a cut of the sourcecode:
Received: from xxx.com (xxx.com [xx.xx.xx.xx])
    by mailgate.xxx.de (8.11.1 (PHNE_35951)/8.11.1) with SMTP id q2JBVHZ12879;
    Mon, 19 Mar 2012 12:31:17 +0100 (MEZ)
Date: Mon, 19 Mar 2012 12:31:17 +0100 (MEZ)
From: helpdesk@xxx.de
Subject: Elec. Delivery Note, 168132165891,PO Number 1561831,from  Tech Data GmbH&  Co. OHG
To: xxx@xxx.de
To:
Message-Id:<13321566773212622347@xxx.com>
Mime-Version: 1.0
Content-Type: multipart/mixed;
    boundary="%xFcGhI5FMOROtKo7Kujjgh56ERTBbB"
X-KENRecTime: 1332156684



Thank you for help

Updated

7 years ago
Summary: An invisible subject of a message which has got the subject → subject not displayed for message which has got the subject header

Comment 11

7 years ago
Can you attach a .eml file of the actual message? I'm curious if there's anything on the blank line after the To: line, e.g., a tab, or if it's completely blank.
Anatol, Hawran ?

Comment 13

6 years ago
we have solved our problem with an new email server.

we switched vom KEN4 to Hmailserver, and the subject displays correct in Thunderbird at IMAP

Comment 14

2 years ago
Anatol, thanks for the update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.