Flash crashes with empty data="" [@ _ftol2 | RtlCheckForOrphanedCriticalSections]

RESOLVED DUPLICATE of bug 575836

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 575836
8 years ago
8 years ago

People

(Reporter: Adam Brunner, Assigned: Benjamin Smedberg)

Tracking

({stackwanted})

1.9.2 Branch
x86
Windows XP
stackwanted
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7

Open an HTML page with a flash object in it with an empty data attribute in Firefox 3.6.7. If Firefox not crashes on load, try to refresh the page and it will.

This is a newly introduced bug, it was good in 3.6.6.

Can reproduce on Windows XP, Windows Vista and Windows 7.

Reproducible: Always

Steps to Reproduce:
1. Open page
2. If not crashes, reload page
Actual Results:  
Firefox crashes

Expected Results:  
Not crashes

The installed flash plugin is the latest 10.1
(Reporter)

Comment 1

8 years ago
Created attachment 458986 [details]
Testcase

Comment 2

8 years ago
https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
http://www.mozilla.com/en-US/plugincheck/
Component: General → Flash (Adobe)
Keywords: stackwanted
Product: Firefox → Plugins
QA Contact: general → adobe-flash
Summary: ActiveX Flash crashes with empty data="" → Flash crashes with empty data=""
Version: unspecified → 10.x
(Reporter)

Comment 3

8 years ago
Shockwave Flash: 10.1 r53 (10.1.53.64)
Test crash ID: f8d1db1a-807e-4357-b30a-7d3b72100721

Thanks for your quick reply!

Comment 4

8 years ago
I can confirm a crash w/ testcase. FF 3.6.7 release, WinXP x64.
bp-9aa03666-a164-4b74-aa04-95eb62100721
bp-61f4a4a8-2a73-4e14-9ba7-714482100721

Comment 5

8 years ago
Signature	_ftol2
UUID	61f4a4a8-2a73-4e14-9ba7-714482100721
Time 	2010-07-21 07:23:58.780907
Uptime	29
Last Crash	33 seconds before submission
Install Age	504 seconds (8.4 minutes) since version was first installed.
Product	Firefox
Version	3.6.7
Build ID	20100713130626
Branch	1.9.2
OS	Windows NT
OS Version	5.2.3790 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 11
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0xffffffffe08c27a6
User Comments	
Processor Notes 	
EMCheckCompatibility	False

This does not appear to be the same as:
Bug 540814 RESOLVED DUPLICATE
Crash when reading downloads.sqlite containing a file associated with Alcohol 120% [@ _ftol2 ]

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	_ftol2 	
1 	ntdll.dll 	RtlCheckForOrphanedCriticalSections 	
2 	mozcrt19.dll 	arena_dalloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4226
3 	mozcrt19.dll 	free 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6017
4 	xul.dll 	nsPluginInstanceOwner::~nsPluginInstanceOwner 	layout/generic/nsObjectFrame.cpp:2591
5 	xul.dll 	nsPluginInstanceOwner::`scalar deleting destructor' 	
6 	xul.dll 	nsPluginInstanceOwner::Release 	layout/generic/nsObjectFrame.cpp:2637
7 	xul.dll 	nsRefPtr<nsHTMLMediaElement>::~nsRefPtr<nsHTMLMediaElement> 	obj-firefox/dist/include/nsAutoPtr.h:956
8 	xul.dll 	nsObjectFrame::StopPluginInternal 	layout/generic/nsObjectFrame.cpp:2412
9 	xul.dll 	nsObjectFrame::StopPlugin 	layout/generic/nsObjectFrame.cpp:2352
10 	xul.dll 	EnumerateFreezables 	content/base/src/nsDocument.cpp:7770
11 	xul.dll 	nsTHashtable<mozilla::plugins::PluginModuleChild::NPObjectData>::s_EnumStub 	obj-firefox/dist/include/nsTHashtable.h:420
12 	xul.dll 	PL_DHashTableEnumerate 	obj-firefox/xpcom/build/pldhash.c:754
13 	xul.dll 	nsTHashtable<nsPtrHashKey<nsIContent> >::EnumerateEntries 	obj-firefox/dist/include/nsTHashtable.h:241
14 	xul.dll 	PresShell::Freeze 	
15 	xul.dll 	DocumentViewerImpl::Destroy 	layout/base/nsDocumentViewer.cpp:1501
16 	xul.dll 	DocumentViewerImpl::Show 	layout/base/nsDocumentViewer.cpp:1918
17 	xul.dll 	nsPresContext::EnsureVisible 	layout/base/nsPresContext.cpp:1588
18 	xul.dll 	PresShell::UnsuppressAndInvalidate 	layout/base/nsPresShell.cpp:4647
19 	xul.dll 	PresShell::UnsuppressPainting 	layout/base/nsPresShell.cpp:4692
20 	xul.dll 	PresShell::sPaintSuppressionCallback 	layout/base/nsPresShell.cpp:2740
21 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:427
22 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:519
23 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
24 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:142
25 	xul.dll 	xul.dll@0x9ac40f 	
26 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:199
27 	mozcrt19.dll 	malloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:5790
28 	xul.dll 	xul.dll@0x30a8e3 	
29 	xul.dll 	xul.dll@0x351e8f 	
30 	firefox.exe 	firefox.exe@0x1b97 	
31 	kernel32.dll 	kernel32.dll@0x189df 	
32 	kernel32.dll 	kernel32.dll@0x27d4f 	
33 	firefox.exe 	firefox.exe@0x183f 	

NPSWF32.dll	10.1.53.64	547FB6F990234E7FAABA5DE4C9F5BB911	NPSWF32.pdb
Status: UNCONFIRMED → NEW
Component: Flash (Adobe) → Plug-ins
Ever confirmed: true
Product: Plugins → Core
QA Contact: adobe-flash → plugins
Summary: Flash crashes with empty data="" → Flash crashes with empty data="" [@ _ftol2 | RtlCheckForOrphanedCriticalSections]
Version: 10.x → 1.9.2 Branch
(Assignee)

Updated

8 years ago
Assignee: nobody → benjamin
blocking2.0: --- → final+
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 575836
You need to log in before you can comment on or make changes to this bug.