Beta page doesn't validate

VERIFIED FIXED in 4.0

Status

www.mozilla.org
General
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: stephend, Assigned: Stephen DesRoches)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
http://www-trunk.stage.mozilla.com/en-US/firefox/beta/ doesn't validate:

http://validator.w3.org/check?uri=http%3A%2F%2Fwww-trunk.stage.mozilla.com%2Fen-US%2Ffirefox%2Fbeta%2F&charset=%28detect+automatically%29&doctype=Inline&group=0
(Assignee)

Comment 1

7 years ago
This is caused by the php function that does browser detection. It's not necessarily related to specifically this page.

The validation change will need to be updated in:

<?=buildPlatformImage('/img/firefox/beta/4/feedback-button.png', 'Feedback button screenshot')?>
(Assignee)

Comment 2

7 years ago
Turns out I was using the php function wrong.

Validation problems fixed in r71076
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> Turns out I was using the php function wrong.
> 
> Validation problems fixed in r71076

Thanks; please mark bugs fixed when you fix them.  I noticed you didn't have the appropriate Bugzilla permissions to do so, so I've granted you edit_bugs and canconfirm; enjoy :-)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
Thanks, Stephen.

Verified FIXED.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 5

7 years ago
Sure, I'm not sure what the practice is on marking bugs as fixed. Do I do that before QA verifies it?
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> Sure, I'm not sure what the practice is on marking bugs as fixed. Do I do that
> before QA verifies it?

Yes; if development is done, please mark it fixed.  The largest part of our workflow is looking at Resolved FIXED bugs, and it's too easy to miss bugs needing QA's attention if they're still in the open state.  Thanks!
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.