Events not loading and cannot change/edit events

RESOLVED DUPLICATE of bug 373251

Status

Calendar
General
--
major
RESOLVED DUPLICATE of bug 373251
7 years ago
7 years ago

People

(Reporter: Tony, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

It started out I could open Sunbird and it would load my events I could not add or edit the events, I restarted my computer after closing Sunbird and now it loads the calender template but will not load the events, the loading wheel on the top right hand corner is spinning but nothing is happening otherwise, I have tried to reset my computer twice since than and no change in what Sunbird is doing.

Reproducible: Always

Steps to Reproduce:
1.Restart Computer
2.Open Sunbird
3.Watch as no events load
Actual Results:  
Sunbird loads my calender template with no events.

Expected Results:  
Sunbird should open and after a short wait load my events for editing and viewing.

If any further information is required or if a solution has been found to my problem please contact us as this problem is causing a lot of grief. I use the program to keep track of my daily appointments and without it I am missing out on a lot of important meetings etc.
Does this also happen with Thunderbird/Lightning?

Please enable calendar.debug.log and calendar.debug.log.verbose in the advanced config editor (Options > Advanced > General > Config Editor) and check your error console for messages.

Comment 2

7 years ago
I can confirm that the edit existing events is not working for me (Windows XP Pro, TB 3.1.6 with Lightning 1.0b2).  I can double click a day on the calendar to create an event and this works fine.  However if I wish to edit the name of this event by double clicking it when it is already in the calendar this works but when I have changed the name and press return to commit my change the event will not change and the cursor continues to flash.  All I am able to do is press ESC to cancel the change.  In order to work around this behaviour I am forced to delete incorrect events and create new ones rather than being able to edit existing ones.  The error console brings up the following error:

job.finalize is not a function
chrome://calendar/content/calendar-views.js
Line 140

I am also unable to right click and select open for existing events, when I do this the error console displays:

this.baseUri is null
file:///C:/Documents and Settings/Mark/Application Data/Thunderbird/Profiles/o4zhtzma.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules/calUtils.jsm -> file:///C:/Documents and Settings/Mark/Application Data/Thunderbird/Profiles/o4zhtzma.default/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js/calDavRequestHandlers.js
Line: 193

I hope this helps.

Thank you.

Comment 3

7 years ago
Fallen, ssitter 
this has the debug info
Severity: critical → major
OS: Windows Vista → All
Confirmed, this is likely an issue with the code that should make sure you only open one event dialog per event. This will be taken care of in bug:
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373251
You need to log in before you can comment on or make changes to this bug.