Last Comment Bug 580724 - When crashreporter.exe is stuck, then SeaMonkey's updater cannot complete.
: When crashreporter.exe is stuck, then SeaMonkey's updater cannot complete.
Status: RESOLVED DUPLICATE of bug 466778
:
Product: SeaMonkey
Classification: Client Software
Component: Installer (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: installer
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 11:37 PDT by Ant
Modified: 2010-12-08 16:51 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Ant 2010-07-21 11:37:39 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.11) Gecko/20100701 SeaMonkey/2.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.11) Gecko/20100701 SeaMonkey/2.0.6

Earlier, I was trying to update my SeaMonkey v2.0.5 to v2.0.6 through its internal updater but it failed -- "The update could not be installed. Please
make sure there are no other copies of SeaMonkey running on your computer, and then restart SeaMonkey to try again." At first, I thought it was a 64-bit Windows 7 HP but then I never ahd this problem in the previous versions upgrades.

I figured it out after an hour investigation.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Run an older SeaMonkey (SM) version behind the latest version for internal updater to see and get updates to upgrade.
2. Get crashreporter.exe to run. For my scenario, it was stuck and never exited from a previous crash.
3. Run internal updater manually.
4. Let it restart and update SM.
5. SM updater should fail.
Actual Results:  
SM updater should fail...

Expected Results:  
SM updater should not fail. It should detect crashreporter.exe running and exit it? Or at least tell users what is still running.

Here is how I figured my update issue out:

I found and read http://kb.mozillazine.org/Software_Update#Software_Update_not_working_properly -- "Another possible solution is to reset the Software Update feature by ending all Firefox processes and then removing 'active-update.xml', 'updates.xml' and the 'updates' folder from the appropriate folder locations (see above)..."

So I followed the instructions from my C:\winstuff\SeaMonkey2. I retried downloading updates manually, installing them, and restarting SM. Same exact problem. :(

I also found logs that was useful. Here's an update.log after deleting updates files:

PREPARE PATCH AccessibleMarshal.dll
PREPARE PATCH MapiProxy.dll
PREPARE PATCH application.ini
PREPARE PATCH chrome/classic.jar
PREPARE PATCH chrome/comm.jar
PREPARE PATCH chrome/en-US.jar
PREPARE PATCH chrome/gloda.jar
PREPARE PATCH chrome/messenger.jar
PREPARE PATCH chrome/newsblog.jar
PREPARE PATCH chrome/pippki.jar
PREPARE PATCH chrome/reporter.jar
PREPARE PATCH chrome/toolkit.jar
PREPARE PATCH components/browser.xpt
PREPARE PATCH components/jar50.dll
PREPARE PATCH components/jsd3250.dll
PREPARE PATCH components/storage-Legacy.js
PREPARE PATCH components/suite.dll
PREPARE PATCH components/xpinstal.dll
PREPARE PATCH crashreporter.exe
PREPARE PATCH defaults/pref/browser-prefs.js
PREPARE PATCH extensions/inspector@mozilla.org/chrome/inspector.jar
PREPARE PATCH extensions/modern@themes.mozilla.org/chrome/modern.jar
PREPARE PATCH extensions/modern@themes.mozilla.org/install.rdf
PREPARE PATCH extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/chatzilla.jar
PREPARE PATCH extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
PREPARE PATCH extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}/chrome/venkman.jar
PREPARE ADD freebl3.chk
PREPARE PATCH freebl3.dll
PREPARE PATCH greprefs/all.js
PREPARE PATCH js3250.dll
PREPARE PATCH modules/gloda/datastore.js
PREPARE PATCH mozMapi32.dll
PREPARE PATCH mozcrt19.dll
PREPARE PATCH nsldap32v60.dll
PREPARE PATCH nsldappr32v60.dll
PREPARE PATCH nsldif32v60.dll
PREPARE PATCH nspr4.dll
PREPARE PATCH nss3.dll
PREPARE PATCH nssckbi.dll
PREPARE ADD nssdbm3.chk
PREPARE PATCH nssdbm3.dll
PREPARE PATCH nssutil3.dll
PREPARE PATCH platform.ini
PREPARE PATCH plc4.dll
PREPARE PATCH plds4.dll
PREPARE PATCH plugins/npnul32.dll
PREPARE PATCH seamonkey.exe
PREPARE PATCH smime3.dll
PREPARE ADD softokn3.chk
PREPARE PATCH softokn3.dll
PREPARE PATCH sqlite3.dll
PREPARE PATCH ssl3.dll
PREPARE PATCH uninstall/helper.exe
PREPARE PATCH updater.exe
PREPARE PATCH xpcom.dll
PREPARE PATCH xpcom_core.dll
PREPARE REMOVE chrome/app-chrome.manifest
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/chatzilla.jar
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/debugqa.jar
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/debugqa.manifest
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/installed-chrome.txt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/abcardWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/abcardWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/ablistWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/addressbookWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/addressbookWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/bmPropsWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/bmPropsWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/bookmark-window.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/bookmark-window16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/calendar-window.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/calendar-window16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/chatzilla-window.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/chatzilla-window16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/chatzilla-window.ico
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/default.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/default16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/downloadManager.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/downloadManager16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/editorWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/editorWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/findBookmarkWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/findBookmarkWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/findHistoryWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/findHistoryWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/history-window.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/history-window16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/jsconsoleWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/jsconsoleWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/JSConsoleWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/main-window.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/main-window16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/messengerWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/messengerWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/msgcomposeWindow.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/msgcomposeWindow16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/venkman-window.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/icons/default/venkman-window16.xpm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE chrome/venkman.jar
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/airbag.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/bookmark.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/bookmarks.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/chatzilla-service.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/components.list
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/contentAreaDropListener.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/contentSecurityPolicy.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/crashreporter.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/crypto-SDR.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/downloadmanager.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/GPSDGeolocationProvider.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/jsctypes.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/msgAsyncPrompter.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/myspell.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsCloseAllWindows.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsDictionary.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsDownloadProgressListener.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsFormAutoComplete.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsINIProcessor.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsInterfaceInfoToIDL.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsKillAll.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsLDAPPrefsService.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsMicrosummaryService.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsPlacesAutoComplete.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsPlacesExpiration.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsResetPref.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsScriptableIO.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsSetDefaultBrowser.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsSetDefaultMail.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsUnsetDefaultMail.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsXmlRpcClient.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/progressDlg.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/search.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/sigonviewer.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/sidebar.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/srchsvc.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/suitetypeaheadfind.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/suitetypeaheadfind.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/urlwidgt.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/util.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/venkman-service.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/wallet.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/walletviewers.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/wlltvwrs.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/wallet.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/walleteditor.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/walletpreview.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/windowsproxy.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xmlextras.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xpinstall.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/winhooks.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xml-rpc.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE compreg.dat
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/VcardSchema.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/FieldSchema.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/SchemaConcat.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/DistinguishedSchema.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/SchemaStrings.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/PositionalSchema.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE defaults/wallet/StateSchema.tbl
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/inspector@mozilla.org/components/components.list
file cannot be removed because it does not exist; skipping
PREPARE REMOVE ; ChatZilla.
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/components/components.list
file cannot be removed because it does not exist; skipping
PREPARE REMOVE ; Venkman.
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}/components/components.list
file cannot be removed because it does not exist; skipping
PREPARE REMOVE greprefs.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE layers.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE modules/JSON.jsm
file cannot be removed because it does not exist; skipping
PREPARE REMOVE xpistub.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE mozilla-runtime.exe
file cannot be removed because it does not exist; skipping
PREPARE REMOVE mozlcms.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE mozsqlite3.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE LICENSE
file cannot be removed because it does not exist; skipping
PREPARE REMOVE Microsoft.VC80.CRT.manifest
file cannot be removed because it does not exist; skipping
PREPARE REMOVE msvcm80.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE msvcp80.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE msvcr80.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE mozcpp19.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE regxpcom.exe
file cannot be removed because it does not exist; skipping
PREPARE REMOVE res/cmessage.txt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE modules/dbViewWrapper.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE modules/mailViewManager.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE modules/quickSearchManager.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE modules/searchSpec.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/install.rdf
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/mozABConduit.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/PalmSyncInstall.exe
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/PalmSyncProxy.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/components/palmsync.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/components/palmsync.xpt
file cannot be removed because it does not exist; skipping
PREPARE REMOVE extensions/p@m/defaults/preferences/palmsync.js
file cannot be removed because it does not exist; skipping
PREPARE REMOVE xpicleanup.exe
file cannot be removed because it does not exist; skipping
PREPARE REMOVE xpti.dat
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/accessibility.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/appcomps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/auth.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/autoconfig.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/caps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/chardet.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/chrome.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/commandlines.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/composer.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/cookie.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/docshell.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/embedcomponents.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/fileview.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/gkgfxthebes.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/gklayout.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/gkplugin.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/htmlpars.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/i18n.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/imglib2.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/import.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/intlapp.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/mail.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/mork.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/mozfind.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/mozldap.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/msgsmime.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/necko.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsappshell.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/oji.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/permissions.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/pipboot.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/pipnss.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/pippki.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/places.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/pref.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/rdf.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/remoteservice.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/satchel.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/spellchecker.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/storagecomps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/system-pref.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/tkautocomplete.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/toolkitcomps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/txmgr.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/uconv.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/ucvmath.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/universalchardet.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/unixproxy.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/webbrwsr.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/widget_gtk2.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/windowds.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xpautocomplete.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xpconnect.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/zipwriter.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE gfxpsshar.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE gkgfx.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE gtkxtbin.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE jsj.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE mozz.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE thebes.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE xul.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE gksvggdiplus.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE jsj3250.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/appshell.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/cmdlines.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/gkparser.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/gkwidget.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/imgicon.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/msgMapi.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/perms.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/spellchk.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/strgcmps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/tkautoc.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/tkitcmps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xpautoc.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xpc3250.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xppref32.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE ; MOZ_STATIC_BUILD
file cannot be removed because it does not exist; skipping
PREPARE REMOVE msgbsutl.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/commandlines.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/htmlpars.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/nsappshell.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/permissions.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/spellchecker.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/storagecomps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/tkautocomplete.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/toolkitcomps.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE components/xpautocomplete.dll
file cannot be removed because it does not exist; skipping
PREPARE REMOVE mozjs.dll
file cannot be removed because it does not exist; skipping
EXECUTE PATCH AccessibleMarshal.dll
EXECUTE PATCH MapiProxy.dll
EXECUTE PATCH application.ini
EXECUTE PATCH chrome/classic.jar
EXECUTE PATCH chrome/comm.jar
EXECUTE PATCH chrome/en-US.jar
EXECUTE PATCH chrome/gloda.jar
EXECUTE PATCH chrome/messenger.jar
EXECUTE PATCH chrome/newsblog.jar
EXECUTE PATCH chrome/pippki.jar
EXECUTE PATCH chrome/reporter.jar
EXECUTE PATCH chrome/toolkit.jar
EXECUTE PATCH components/browser.xpt
EXECUTE PATCH components/jar50.dll
EXECUTE PATCH components/jsd3250.dll
EXECUTE PATCH components/storage-Legacy.js
EXECUTE PATCH components/suite.dll
EXECUTE PATCH components/xpinstal.dll
EXECUTE PATCH crashreporter.exe
remove failed: -1,13 (crashreporter.exe)
### execution failed
FINISH PATCH AccessibleMarshal.dll
FINISH PATCH MapiProxy.dll
FINISH PATCH application.ini
FINISH PATCH chrome/classic.jar
FINISH PATCH chrome/comm.jar
FINISH PATCH chrome/en-US.jar
FINISH PATCH chrome/gloda.jar
FINISH PATCH chrome/messenger.jar
FINISH PATCH chrome/newsblog.jar
FINISH PATCH chrome/pippki.jar
FINISH PATCH chrome/reporter.jar
FINISH PATCH chrome/toolkit.jar
FINISH PATCH components/browser.xpt
FINISH PATCH components/jar50.dll
FINISH PATCH components/jsd3250.dll
FINISH PATCH components/storage-Legacy.js
FINISH PATCH components/suite.dll
FINISH PATCH components/xpinstal.dll
FINISH PATCH crashreporter.exe
copy_file: failed to open: crashreporter.exe,13
FINISH PATCH defaults/pref/browser-prefs.js
copy_file: failed to open or stat: -1,defaults/pref/browser-prefs.js.moz-backup,2
FINISH PATCH extensions/inspector@mozilla.org/chrome/inspector.jar
copy_file: failed to open or stat: -1,extensions/inspector@mozilla.org/chrome/inspector.jar.moz-backup,2
FINISH PATCH extensions/modern@themes.mozilla.org/chrome/modern.jar
copy_file: failed to open or stat: -1,extensions/modern@themes.mozilla.org/chrome/modern.jar.moz-backup,2
FINISH PATCH extensions/modern@themes.mozilla.org/install.rdf
copy_file: failed to open or stat: -1,extensions/modern@themes.mozilla.org/install.rdf.moz-backup,2
FINISH PATCH extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/chatzilla.jar
copy_file: failed to open or stat: -1,extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/chrome/chatzilla.jar.moz-backup,2
FINISH PATCH extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
copy_file: failed to open or stat: -1,extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf.moz-backup,2
FINISH PATCH extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}/chrome/venkman.jar
copy_file: failed to open or stat: -1,extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}/chrome/venkman.jar.moz-backup,2
FINISH ADD freebl3.chk
copy_file: failed to open or stat: -1,freebl3.chk.moz-backup,2
FINISH PATCH freebl3.dll
copy_file: failed to open or stat: -1,freebl3.dll.moz-backup,2
FINISH PATCH greprefs/all.js
copy_file: failed to open or stat: -1,greprefs/all.js.moz-backup,2
FINISH PATCH js3250.dll
copy_file: failed to open or stat: -1,js3250.dll.moz-backup,2
FINISH PATCH modules/gloda/datastore.js
copy_file: failed to open or stat: -1,modules/gloda/datastore.js.moz-backup,2
FINISH PATCH mozMapi32.dll
copy_file: failed to open or stat: -1,mozMapi32.dll.moz-backup,2
FINISH PATCH mozcrt19.dll
copy_file: failed to open or stat: -1,mozcrt19.dll.moz-backup,2
FINISH PATCH nsldap32v60.dll
copy_file: failed to open or stat: -1,nsldap32v60.dll.moz-backup,2
FINISH PATCH nsldappr32v60.dll
copy_file: failed to open or stat: -1,nsldappr32v60.dll.moz-backup,2
FINISH PATCH nsldif32v60.dll
copy_file: failed to open or stat: -1,nsldif32v60.dll.moz-backup,2
FINISH PATCH nspr4.dll
copy_file: failed to open or stat: -1,nspr4.dll.moz-backup,2
FINISH PATCH nss3.dll
copy_file: failed to open or stat: -1,nss3.dll.moz-backup,2
FINISH PATCH nssckbi.dll
copy_file: failed to open or stat: -1,nssckbi.dll.moz-backup,2
FINISH ADD nssdbm3.chk
copy_file: failed to open or stat: -1,nssdbm3.chk.moz-backup,2
FINISH PATCH nssdbm3.dll
copy_file: failed to open or stat: -1,nssdbm3.dll.moz-backup,2
FINISH PATCH nssutil3.dll
copy_file: failed to open or stat: -1,nssutil3.dll.moz-backup,2
FINISH PATCH platform.ini
copy_file: failed to open or stat: -1,platform.ini.moz-backup,2
FINISH PATCH plc4.dll
copy_file: failed to open or stat: -1,plc4.dll.moz-backup,2
FINISH PATCH plds4.dll
copy_file: failed to open or stat: -1,plds4.dll.moz-backup,2
FINISH PATCH plugins/npnul32.dll
copy_file: failed to open or stat: -1,plugins/npnul32.dll.moz-backup,2
FINISH PATCH seamonkey.exe
copy_file: failed to open or stat: -1,seamonkey.exe.moz-backup,2
FINISH PATCH smime3.dll
copy_file: failed to open or stat: -1,smime3.dll.moz-backup,2
FINISH ADD softokn3.chk
copy_file: failed to open or stat: -1,softokn3.chk.moz-backup,2
FINISH PATCH softokn3.dll
copy_file: failed to open or stat: -1,softokn3.dll.moz-backup,2
FINISH PATCH sqlite3.dll
copy_file: failed to open or stat: -1,sqlite3.dll.moz-backup,2
FINISH PATCH ssl3.dll
copy_file: failed to open or stat: -1,ssl3.dll.moz-backup,2
FINISH PATCH uninstall/helper.exe
copy_file: failed to open or stat: -1,uninstall/helper.exe.moz-backup,2
FINISH PATCH updater.exe
copy_file: failed to open or stat: -1,updater.exe.moz-backup,2
FINISH PATCH xpcom.dll
copy_file: failed to open or stat: -1,xpcom.dll.moz-backup,2
FINISH PATCH xpcom_core.dll
copy_file: failed to open or stat: -1,xpcom_core.dll.moz-backup,2
FINISH REMOVE chrome/app-chrome.manifest
FINISH REMOVE chrome/chatzilla.jar
FINISH REMOVE chrome/debugqa.jar
FINISH REMOVE chrome/debugqa.manifest
FINISH REMOVE chrome/installed-chrome.txt
FINISH REMOVE chrome/icons/default/abcardWindow.xpm
FINISH REMOVE chrome/icons/default/abcardWindow16.xpm
FINISH REMOVE chrome/icons/default/ablistWindow.xpm
FINISH REMOVE chrome/icons/default/addressbookWindow.xpm
FINISH REMOVE chrome/icons/default/addressbookWindow16.xpm
FINISH REMOVE chrome/icons/default/bmPropsWindow.xpm
FINISH REMOVE chrome/icons/default/bmPropsWindow16.xpm
FINISH REMOVE chrome/icons/default/bookmark-window.xpm
FINISH REMOVE chrome/icons/default/bookmark-window16.xpm
FINISH REMOVE chrome/icons/default/calendar-window.xpm
FINISH REMOVE chrome/icons/default/calendar-window16.xpm
FINISH REMOVE chrome/icons/default/chatzilla-window.xpm
FINISH REMOVE chrome/icons/default/chatzilla-window16.xpm
FINISH REMOVE chrome/icons/default/chatzilla-window.ico
FINISH REMOVE chrome/icons/default/default.xpm
FINISH REMOVE chrome/icons/default/default16.xpm
FINISH REMOVE chrome/icons/default/downloadManager.xpm
FINISH REMOVE chrome/icons/default/downloadManager16.xpm
FINISH REMOVE chrome/icons/default/editorWindow.xpm
FINISH REMOVE chrome/icons/default/editorWindow16.xpm
FINISH REMOVE chrome/icons/default/findBookmarkWindow.xpm
FINISH REMOVE chrome/icons/default/findBookmarkWindow16.xpm
FINISH REMOVE chrome/icons/default/findHistoryWindow.xpm
FINISH REMOVE chrome/icons/default/findHistoryWindow16.xpm
FINISH REMOVE chrome/icons/default/history-window.xpm
FINISH REMOVE chrome/icons/default/history-window16.xpm
FINISH REMOVE chrome/icons/default/jsconsoleWindow.xpm
FINISH REMOVE chrome/icons/default/jsconsoleWindow16.xpm
FINISH REMOVE chrome/icons/default/JSConsoleWindow.xpm
FINISH REMOVE chrome/icons/default/main-window.xpm
FINISH REMOVE chrome/icons/default/main-window16.xpm
FINISH REMOVE chrome/icons/default/messengerWindow.xpm
FINISH REMOVE chrome/icons/default/messengerWindow16.xpm
FINISH REMOVE chrome/icons/default/msgcomposeWindow.xpm
FINISH REMOVE chrome/icons/default/msgcomposeWindow16.xpm
FINISH REMOVE chrome/icons/default/venkman-window.xpm
FINISH REMOVE chrome/icons/default/venkman-window16.xpm
FINISH REMOVE chrome/venkman.jar
FINISH REMOVE components/airbag.xpt
FINISH REMOVE components/bookmark.dll
FINISH REMOVE components/bookmarks.xpt
FINISH REMOVE components/chatzilla-service.js
FINISH REMOVE components/components.list
FINISH REMOVE components/contentAreaDropListener.js
FINISH REMOVE components/contentSecurityPolicy.js
FINISH REMOVE components/crashreporter.xpt
FINISH REMOVE components/crypto-SDR.js
FINISH REMOVE components/downloadmanager.xpt
FINISH REMOVE components/GPSDGeolocationProvider.js
FINISH REMOVE components/jsctypes.dll
FINISH REMOVE components/msgAsyncPrompter.js
FINISH REMOVE components/myspell.dll
FINISH REMOVE components/nsCloseAllWindows.js
FINISH REMOVE components/nsDictionary.js
FINISH REMOVE components/nsDownloadProgressListener.js
FINISH REMOVE components/nsFormAutoComplete.js
FINISH REMOVE components/nsINIProcessor.js
FINISH REMOVE components/nsInterfaceInfoToIDL.js
FINISH REMOVE components/nsKillAll.js
FINISH REMOVE components/nsLDAPPrefsService.js
FINISH REMOVE components/nsMicrosummaryService.js
FINISH REMOVE components/nsPlacesAutoComplete.js
FINISH REMOVE components/nsPlacesExpiration.js
FINISH REMOVE components/nsResetPref.js
FINISH REMOVE components/nsScriptableIO.js
FINISH REMOVE components/nsSetDefaultBrowser.js
FINISH REMOVE components/nsSetDefaultMail.js
FINISH REMOVE components/nsUnsetDefaultMail.js
FINISH REMOVE components/nsXmlRpcClient.js
FINISH REMOVE components/progressDlg.xpt
FINISH REMOVE components/search.xpt
FINISH REMOVE components/sigonviewer.xpt
FINISH REMOVE components/sidebar.xpt
FINISH REMOVE components/srchsvc.dll
FINISH REMOVE components/suitetypeaheadfind.xpt
FINISH REMOVE components/suitetypeaheadfind.dll
FINISH REMOVE components/urlwidgt.xpt
FINISH REMOVE components/util.xpt
FINISH REMOVE components/venkman-service.js
FINISH REMOVE components/wallet.dll
FINISH REMOVE components/walletviewers.dll
FINISH REMOVE components/wlltvwrs.dll
FINISH REMOVE components/wallet.xpt
FINISH REMOVE components/walleteditor.xpt
FINISH REMOVE components/walletpreview.xpt
FINISH REMOVE components/windowsproxy.dll
FINISH REMOVE components/xmlextras.dll
FINISH REMOVE components/xpinstall.dll
FINISH REMOVE components/winhooks.xpt
FINISH REMOVE components/xml-rpc.xpt
FINISH REMOVE compreg.dat
FINISH REMOVE defaults/wallet/VcardSchema.tbl
FINISH REMOVE defaults/wallet/FieldSchema.tbl
FINISH REMOVE defaults/wallet/SchemaConcat.tbl
FINISH REMOVE defaults/wallet/DistinguishedSchema.tbl
FINISH REMOVE defaults/wallet/SchemaStrings.tbl
FINISH REMOVE defaults/wallet/PositionalSchema.tbl
FINISH REMOVE defaults/wallet/StateSchema.tbl
FINISH REMOVE extensions/inspector@mozilla.org/components/components.list
FINISH REMOVE ; ChatZilla.
FINISH REMOVE extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}/components/components.list
FINISH REMOVE ; Venkman.
FINISH REMOVE extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}/components/components.list
FINISH REMOVE greprefs.js
FINISH REMOVE layers.dll
FINISH REMOVE modules/JSON.jsm
FINISH REMOVE xpistub.dll
FINISH REMOVE mozilla-runtime.exe
FINISH REMOVE mozlcms.dll
FINISH REMOVE mozsqlite3.dll
FINISH REMOVE LICENSE
FINISH REMOVE Microsoft.VC80.CRT.manifest
FINISH REMOVE msvcm80.dll
FINISH REMOVE msvcp80.dll
FINISH REMOVE msvcr80.dll
FINISH REMOVE mozcpp19.dll
FINISH REMOVE regxpcom.exe
FINISH REMOVE res/cmessage.txt
FINISH REMOVE modules/dbViewWrapper.js
FINISH REMOVE modules/mailViewManager.js
FINISH REMOVE modules/quickSearchManager.js
FINISH REMOVE modules/searchSpec.js
FINISH REMOVE extensions/p@m/install.rdf
FINISH REMOVE extensions/p@m/mozABConduit.dll
FINISH REMOVE extensions/p@m/PalmSyncInstall.exe
FINISH REMOVE extensions/p@m/PalmSyncProxy.dll
FINISH REMOVE extensions/p@m/components/palmsync.dll
FINISH REMOVE extensions/p@m/components/palmsync.xpt
FINISH REMOVE extensions/p@m/defaults/preferences/palmsync.js
FINISH REMOVE xpicleanup.exe
FINISH REMOVE xpti.dat
FINISH REMOVE components/accessibility.dll
FINISH REMOVE components/appcomps.dll
FINISH REMOVE components/auth.dll
FINISH REMOVE components/autoconfig.dll
FINISH REMOVE components/caps.dll
FINISH REMOVE components/chardet.dll
FINISH REMOVE components/chrome.dll
FINISH REMOVE components/commandlines.dll
FINISH REMOVE components/composer.dll
FINISH REMOVE components/cookie.dll
FINISH REMOVE components/docshell.dll
FINISH REMOVE components/embedcomponents.dll
FINISH REMOVE components/fileview.dll
FINISH REMOVE components/gkgfxthebes.dll
FINISH REMOVE components/gklayout.dll
FINISH REMOVE components/gkplugin.dll
FINISH REMOVE components/htmlpars.dll
FINISH REMOVE components/i18n.dll
FINISH REMOVE components/imglib2.dll
FINISH REMOVE components/import.dll
FINISH REMOVE components/intlapp.dll
FINISH REMOVE components/mail.dll
FINISH REMOVE components/mork.dll
FINISH REMOVE components/mozfind.dll
FINISH REMOVE components/mozldap.dll
FINISH REMOVE components/msgsmime.dll
FINISH REMOVE components/necko.dll
FINISH REMOVE components/nsappshell.dll
FINISH REMOVE components/oji.dll
FINISH REMOVE components/permissions.dll
FINISH REMOVE components/pipboot.dll
FINISH REMOVE components/pipnss.dll
FINISH REMOVE components/pippki.dll
FINISH REMOVE components/places.dll
FINISH REMOVE components/pref.dll
FINISH REMOVE components/rdf.dll
FINISH REMOVE components/remoteservice.dll
FINISH REMOVE components/satchel.dll
FINISH REMOVE components/spellchecker.dll
FINISH REMOVE components/storagecomps.dll
FINISH REMOVE components/system-pref.dll
FINISH REMOVE components/tkautocomplete.dll
FINISH REMOVE components/toolkitcomps.dll
FINISH REMOVE components/txmgr.dll
FINISH REMOVE components/uconv.dll
FINISH REMOVE components/ucvmath.dll
FINISH REMOVE components/universalchardet.dll
FINISH REMOVE components/unixproxy.dll
FINISH REMOVE components/webbrwsr.dll
FINISH REMOVE components/widget_gtk2.dll
FINISH REMOVE components/windowds.dll
FINISH REMOVE components/xpautocomplete.dll
FINISH REMOVE components/xpconnect.dll
FINISH REMOVE components/zipwriter.dll
FINISH REMOVE gfxpsshar.dll
FINISH REMOVE gkgfx.dll
FINISH REMOVE gtkxtbin.dll
FINISH REMOVE jsj.dll
FINISH REMOVE mozz.dll
FINISH REMOVE thebes.dll
FINISH REMOVE xul.dll
FINISH REMOVE gksvggdiplus.dll
FINISH REMOVE jsj3250.dll
FINISH REMOVE components/appshell.dll
FINISH REMOVE components/cmdlines.dll
FINISH REMOVE components/gkparser.dll
FINISH REMOVE components/gkwidget.dll
FINISH REMOVE components/imgicon.dll
FINISH REMOVE components/msgMapi.dll
FINISH REMOVE components/perms.dll
FINISH REMOVE components/spellchk.dll
FINISH REMOVE components/strgcmps.dll
FINISH REMOVE components/tkautoc.dll
FINISH REMOVE components/tkitcmps.dll
FINISH REMOVE components/xpautoc.dll
FINISH REMOVE components/xpc3250.dll
FINISH REMOVE components/xppref32.dll
FINISH REMOVE ; MOZ_STATIC_BUILD
FINISH REMOVE msgbsutl.dll
FINISH REMOVE components/commandlines.dll
FINISH REMOVE components/htmlpars.dll
FINISH REMOVE components/nsappshell.dll
FINISH REMOVE components/permissions.dll
FINISH REMOVE components/spellchecker.dll
FINISH REMOVE components/storagecomps.dll
FINISH REMOVE components/tkautocomplete.dll
FINISH REMOVE components/toolkitcomps.dll
FINISH REMOVE components/xpautocomplete.dll
FINISH REMOVE mozjs.dll
failed: 7
calling QuitProgressUI


As you can see: EXECUTE PATCH crashreporter.exe
remove failed: -1,13 (crashreporter.exe)
### execution failed


I don't know if I will be able to reproduce this again since this is a rare scenario. Basically, crashreporter.exe process needs to be stuck for the update to fail.
Comment 1 timeless 2010-07-21 12:17:53 PDT
yeah, the installer should be able to ask crashreporter to quit and then offer to (or just) force quit it
Comment 2 Robert Kaiser (not working on stability any more) 2010-12-08 15:27:04 PST
Robert, is this a known general installer problem? Do we have a solution in sight?
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2010-12-08 15:36:23 PST
This is an updater bug and has nothing to do with the installer. The installer already handles files in use. Also, this is bug 466778 and is fixed on trunk. I will likely be backporting it to 1.9.2 as long as I can get approval.
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2010-12-08 15:43:55 PST
btw: I suggest duping this bug against bug 466778 and leave that up to you in case you'd prefer to leave this bug open.
Comment 5 Robert Kaiser (not working on stability any more) 2010-12-08 16:51:41 PST
duping per comment #4, thanks for the input!

*** This bug has been marked as a duplicate of bug 466778 ***

Note You need to log in before you can comment on or make changes to this bug.