If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox reverses the RGB color values of heading colors set using CSS

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: leifjohn, Unassigned)

Tracking

4.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)

Firefox does not display the correct colors for heading tags (h1, h2, h3, h4). It seems like it is reversing the RGB values. Sometimes changing the font-size property to a smaller size for the heading tags will correct the color which is weird, but it has to be pretty small for this to happen.

Reproducible: Always

Steps to Reproduce:
1. Go to the link above.
2. Change the hex color code for the h1 heading tag to red (#FF0000)
3. Click the button and you will see it displays blue instead.
4. Try this for any hex color code and it will reverse the rgb values.
Actual Results:  
Firefox reversed the RGB values for the heading color and displayed the heading in blue.

Expected Results:  
The heading should be displayed in red.

I have disabled all add-ons, cleared history and cache, done w3c validation checks on html, css, etc. Everything checks out perfect. This is driving my crazy.

Comment 1

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7

Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2pre) Gecko/20100720 Minefield/4.0b2pre

Works fine for me
(Reporter)

Comment 2

7 years ago
This is really weird. Could this have anything to do with my graphics card (ATI Radeon HD 3870)? It works fine in IE and Chrome.

Comment 3

7 years ago
This is probably a question for
  http://support.mozilla.com/  or
  http://forums.mozillazine.org/viewforum.php?f=38

Updated

7 years ago
Version: unspecified → 3.6 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
(Reporter)

Comment 5

6 years ago
I have updated to the latest version 4.0.1 and still have the same issued. I mostly use chrome now because it does not screw up the colors like FF still does.

(In reply to comment #4)
> Reporter, Firefox 4.0.1 has been released, and it features significant
> improvements over previous releases. Can you please update to Firefox 4.0.1
> or later, and retest your bug? Please also create a fresh profile (
> http://support.mozilla.com/kb/Managing+profiles), update your plugins
> (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and
> Operating system to the latest versions available. 
> 
> If you still continue to see this issue, please comment. If you do not,
> please close this bug as RESOLVED > WORKSFORME
> 
> filter: prefirefox4uncobugs

Updated

6 years ago
Version: 3.6 Branch → 4.0 Branch
I'd suspect you have an addon or userChrome.css change that's causing this. Try checking the element with Firebug or DOM Inspector to see what CSS rules are being applied?

WFM, and if this was widespread there would be lots of reports.

Comment 7

5 years ago
I've the same issue.

When I use the color #FFCC00 as background-color, it is shown fine as a yellow-color. If I use it in a H1 or H2 Tag, I see a blue/green-color (the color for #00CCFF).

When I look in the style with firebug, I can see the right colorcode: #FFCC00 but still the wrong color.
When I change it to #00CCFF I see the color I should have with #FFCC00

I've got this Bug with the last released version and with the last released betaversion...

Any help would be appropriate, even a workaround

Comment 8

5 years ago
(In reply to Rico from comment #7)
> I've the same issue.
> 
> ...
> 
> Any help would be appropriate, even a workaround

I found a workaround. I think its not a firefox problem, it is a windows XP designe problem...

I changed my Windows Designe under

START -> Control Panel -> System -> Advanced -> Performance Settings...

to the Adjust for best performance

Since then, I can't reproduce the bug
wfm per comment 8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.