If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsUrlbarHistory::nsUrlbarHistory leaks RDFContainerUtilsImpl

VERIFIED FIXED

Status

()

Core
Document Navigation
P3
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: dbaron, Assigned: Radha on family leave (not reading bugmail))

Tracking

({mlk})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tind-mlk])

Attachments

(1 attachment)

The constructor of nsUrlbarHistory makes 3 calls to GetService and places owning
pointers into global variables.  Only 2 of these 3 are balanced in the
destructor, so the RDFContainerUtilsImpl leaks.  (It's also not clear to me why
these are global variables and not member variables.  What if 2 nsUrlbarHistory
are created??)
Keywords: mlk
Summary: nsUrlbarHistory::nsUrlbarHistory leaks 2 services → nsUrlbarHistory::nsUrlbarHistory leaks RDFContainerUtilsImpl
Whiteboard: [tind-mlk]
Created attachment 18076 [details] [diff] [review]
patch to fix the leak
r=ducarroz

Comment 3

17 years ago
sr=waterson
Checked in fix to the trunk. Since the bug was caused by the patch for 53922, it
is fixed in the branch too as part of the 53922 checkins in the branch.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.