[k] User stats on answers page

VERIFIED FIXED in 2.2

Status

support.mozilla.org
Questions
P4
normal
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: rrosario, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Currently we show "999 posts  999 answers" under the user's avatar on the answers page.
Duplicate of this bug: 582514

Comment 2

8 years ago
http://github.com/jsocol/kitsune/commit/1c75371b9043cf88ae78c45d7a4b96924912c016
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified posts and answers updates correctly.
Status: RESOLVED → VERIFIED

Comment 4

8 years ago
What is being counted as "answer" here? I can think of a few options:

1 Number of replies that have at least one helpful vote
2 Number of helpful votes in total (meaning one reply could count as more than one "answer")
3 Only the number of replies that the OP marked as the solution

#3 is the least preferred solution as that will always be a very low number. Between #1 and #2, I think I would prefer #2 as that can give contributors a higher ratio between "replies" and "answers".

That said, we may need to clarify what "answers" mean as it's vague. Could we say something like "x users helped" instead (assuming we're using #2 above)? Alternatively, if we're using #1, could we call it "x helpful answers"?
I was told that it was implemented based on #3- replies marked as a solution. I agree that the term 'answers' is a bit vague and could be counted more broadly.

Comment 6

8 years ago
While it's good that we are able to track #3 (it will come in handy when developing a more thorough Karma system), I don't think it's the best metric we can show here.

Since this is another example of how the spec wasn't clear, let's keep this in 2.2 but update it with a more encouraging (to contributors) metric in a future release, as well as updating the label to better explain what it means.

Cc'ing Kadir, who will be working on a Karma PRD this quarter.
You need to log in before you can comment on or make changes to this bug.