Won't Sort By Unread Then Date

RESOLVED DUPLICATE of bug 57898

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 57898
8 years ago
4 years ago

People

(Reporter: thestenz, Unassigned)

Tracking

x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7
Build Identifier: Thunderbird 3.1.1

Email list sort does not sort by unread then date like Version 2, Netscape Mail, Microsoft Entourage, and every other mail program I can think of.After unread mail, mail is sorted haphazardly.

Reproducible: Always

Steps to Reproduce:
1.Sort by unread.
2.Will not work ascending or descending.
3.
Actual Results:  
Unread mail is followed by haphazard list of of read messages not sorted by date.

Expected Results:  
Unread mail sorted by date at top, followed by read mail sorted by date as in previous versions.

See above.
(Reporter)

Updated

8 years ago
Summary: Won't Sort By Unread The Date → Won't Sort By Unread Then Date
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1

Comment 1

8 years ago
I don't get a random order, but it in some mailboxes I get Unread in descending order followed by descending order of read messages, but in other mailboxes I get Unread in descending order followed by read mail in *Ascending* order!  This means that I get my newest, most important mail followed by my *oldest* least important mail next.

Comment 2

8 years ago
I stand *slightly* corrected.  Now both my inboxes are sorted with unread in one order and read messages in the *opposite* order--most annoying.  Is there a workaround to make 3.1.2 be like previous versions?  (or should I just downgrade?)

Comment 3

8 years ago
Right...  This is insane!  As soon as you read a message, the next time you come back to that inbox (I have two), the window scrolls way down to the bottom, because the unread messages are at the top and read messages are at the bottom of the list.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 57898
You need to log in before you can comment on or make changes to this bug.