Closed Bug 580979 Opened 10 years ago Closed 9 years ago

Saving images or pages as PDF should be allowed

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set

Tracking

(fennec2.0+)

RESOLVED DUPLICATE of bug 593408
Tracking Status
fennec 2.0+ ---

People

(Reporter: ahoza, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Android; Linux armv7l;en-US;rv:2.0b3pre) Gecko/20100717 Namoroka / 4.0b3pre Fennec/2.0a1pre

Save file dialog shouldn't be displayed if one doesn't have the rights to view/alter folder tree. 

Reproducible: Always

Steps to Reproduce:
1. Go to slickdeals.net
2. Tap and hold down on the Slickdeals banner image link on the top left side of the page
3. Select "Save Image"
4. On the system save image dialog, save the image to a folder of your choice.

Actual Results:  
Folder structure is not displayed in system save image dialog; one cannot create a new folder to save the file.
Perhaps this is not the case when user gains root access (haven't tried this to see the behavior)
Either way images should could be saved to a default folder (just like for Nokia N900) and the dialog not to be displayed anymore.

Expected Results:  
The Slickdeals banner should be saved to the folder one chose.

Device: HTC Desire A8181

Native browser on HTC desire A8181 saves downloaded images to: Photos->All downloads
OS: Other → Android
Hardware: Other → ARM
Same problem when trying to save pages as PDF. Changing summary.
Summary: Saving images should be allowed → Saving images or pages as PDF should be allowed
This sort of works for me.  The folder structure shows up, but only after about 30 seconds has passed.   I am then able to save a file.

The bug here might revolve around why the change folder file structure takes so long to appear on the n900.   

Can someone else confirm if they are seeing this?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Tony - I thought the original bug was Android only?
actually you're right, i overlooked that.  disregard my comment, as n900 is fine.
tracking-fennec: --- → 2.0+
(In reply to comment #0)

> Either way images should could be saved to a default folder (just like for
> Nokia N900) and the dialog not to be displayed anymore.

That is exactly what we do now, or will when bug 593408 lands. I am duping this bug to bug 593408.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593408
You need to log in before you can comment on or make changes to this bug.