Firefox Button vertical position is off on maximized windows when advanced appearance setting 'border padding' is set to a non-default value

RESOLVED FIXED

Status

()

Core
Widget: Win32
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: marcus, Assigned: jimm)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100722 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3pre) Gecko/20100722 Minefield/4.0b3pre

Changing Border Padding size (Windows Control Panel > Appearance and Personalization > Personalization > Window Color and Appearance > Advanced appearance settings...) causes the Firefox Button changes its position in the title bar when the browser window is maximized

Reproducible: Always

Steps to Reproduce:
1.Change Border Padding size
2.Maximize Firefox window
Actual Results:  
If the Border Padding size is less than 4, the Firefox Button will be moved down, creating a small gap (see picture)
If the Border Padding size is more than 4, the Firefox Button will be moved up, cropping part of the button

Expected Results:  
The Firefox Button should be in the same position
(Reporter)

Updated

8 years ago
(Reporter)

Comment 1

8 years ago
Created attachment 459431 [details]
Screenshot

Updated

8 years ago
Blocks: 513162
Component: Theme → Widget: Win32
Product: Firefox → Core
QA Contact: theme → win32
(Assignee)

Updated

8 years ago
Summary: Firefox Button changes vertical position after Border Padding resizing → Firefox Button vertical position is off on maximized windows when advanced appearance setting 'border padding' is set to a non-default value
(Assignee)

Updated

8 years ago
Assignee: nobody → jmathies
(Assignee)

Comment 2

8 years ago
This should block as it could be quite annoying for users who prefer maximized browser windows (and shouldn't be too hard to address).
Severity: trivial → normal
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
Version: unspecified → Trunk
blocking2.0: ? → final+
(Assignee)

Updated

8 years ago
No longer blocks: 513162
(Assignee)

Updated

8 years ago
Depends on: 575870
This should block the meta bug for Firefox, bug 556174
The issue here is this code:

https://bug574821.bugzilla.mozilla.org/attachment.cgi?id=454364

which was added for bug 574821.

The magic 8px number here really needs to be the size of the vertical refresh margin.
I tried doing this by using the same approach used for bug 575245, i.e. removing the css fix from bug 574821 and instead adjust mNonClientOffset.top.

This resulted in perfect display, but unfortunately, the window control buttons in the upper right corner (minimize, maximize, close) were non-functional.

At first I thought this was because I had changed the offset so much that although the buttons were still positioned as expected the hot area for the mouse selection was off the screen top.

I tried just adjusting the offset by one pixel, which should have at least left some area of the button that worked, but it did not.  I have no idea why this happens.
(Assignee)

Comment 6

8 years ago
(In reply to comment #5)
> I tried doing this by using the same approach used for bug 575245, i.e.
> removing the css fix from bug 574821 and instead adjust mNonClientOffset.top.
> 
> This resulted in perfect display, but unfortunately, the window control buttons
> in the upper right corner (minimize, maximize, close) were non-functional.
> 
> At first I thought this was because I had changed the offset so much that
> although the buttons were still positioned as expected the hot area for the
> mouse selection was off the screen top.
> 
> I tried just adjusting the offset by one pixel, which should have at least left
> some area of the button that worked, but it did not.  I have no idea why this
> happens.

The css was a temp fix when we landed the titlebar code. The real fix is to set the upper margin for content on the window using the system's border padding. That's what the patch in bug 575870 does, in connection with the addition of new style properties via bug 574454. (These should land sometime next week.)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 585629
(Assignee)

Comment 8

8 years ago
Fixed by the landings in bug 575870 & bug 574454.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.