The "Do this automatically for files like this from now on" not working

RESOLVED DUPLICATE of bug 453455

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 453455
8 years ago
8 years ago

People

(Reporter: Andy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.7) Gecko/20100713 Firefox/3.6.7 ( .NET CLR 3.5.30729)

I have this same problem as ID550503 but with files in Excel and MS Word.  What could be the reason that despite checking the box "Do this automatically for files like this from now on" and the fact that in Tools/Options/Applications I have it set up that Excel and Word files should be opened with Excel and Word I always get the pop up window asking me what application to use?  It happens on every file I open.

Reproducible: Always

Steps to Reproduce:
1.Click on a file in Gmail
2.The Open window pops up even though I have that type of file already set to open in a specific application
3.
Actual Results:  
The pop up window always opens up.

Expected Results:  
The pop up window should not open because I have everything set to have it automatically open in a predetermined application.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 453455
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 453455 ***

I went to that bug and don't understand it.  Is there a fix for this or not?  I'm not technical and don't know what "content-disposition: attachment" means.  Can you take a minute and just tell me if my problem is being looked into?  Thanks for the help.

Comment 3

8 years ago
There are a couple standards documents that outline how files marked as attachments should be handled. Namely they should not be shown in the browser window. Firefox brings up the save dialog for anything sent with "content-disposition: attachment".

bug 453455 comment 18 does a fairly good job of covering the issues and some proposed solutions. There is no fix in Firefox yet. There might be extensions that modify this behavior.
You need to log in before you can comment on or make changes to this bug.