Closed Bug 581153 Opened 12 years ago Closed 12 years ago

Removing persona does not give an undo option when uninstalled from details view

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla2.0b3

People

(Reporter: ashah, Unassigned)

References

Details

(Whiteboard: [4b2])

Steps to reproduce:
1. Install around 4 to 5 personas.
2. Go to Tools > Add-ons > Themes.
3. Double click on any persona. This will open up the details of that individual persona.
4. There will be a remove button on the right hand side. Click on the remove button.
5. This will remove the persona and bring the browser to the default theme. 

Expected result:
You should get the message to undo this action.

Actual result:
There is no notification to undo the removal of the persona. 

Build ID:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Component: getpersonas.com → Add-ons Manager
Product: Websites → Toolkit
QA Contact: getpersonas-com → add-ons.manager
This is similar to removing an extension, switching to another pane, and going back. We don't persist the post-action items. Those are simply gone.

Dave, can you find a better summary for this bug? As far as I can see we haven't filed such one yet.
Version: unspecified → Trunk
Depends on: 553494
Summary: Removing persona does not give an undo option → Removing persona does not give an undo option when uninstalled from details view
Version: Trunk → unspecified
Dave shall I file a follow-up for the comment I gave above? It's probably the bug this one will depend on, because it doesn't only happen for personas.
(In reply to comment #2)
> Dave shall I file a follow-up for the comment I gave above? It's probably the
> bug this one will depend on, because it doesn't only happen for personas.

I have a fix for it in bug 553494 already.
Fixed by bug 553494
Status: NEW → RESOLVED
Closed: 12 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b3
Status: RESOLVED → VERIFIED
Verified on:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
verified on:

Mozilla/5.0 (Windows; Windows NT 6.0; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.